[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: erratic ps/2 mouse behavior

On Sat, Jul 22, 2000 at 06:06:51PM -0800, Ethan Benson wrote
> I have installed debian potato on a 600Mhz Athlon system and have been
> having problems with the mouse:
> the problem is most noticable in X but also occurs in the console with
> gpm, 
> when i move the mouse it will at times go out of control, the pointer
> starts jumping around the screen extremely fast with the buttons going
> off randomly (i am not clicking the mouse buttons, but the windowmaker
> menu, and window menus appear and my workspaces are switched around
> when the mouse `clicks' my windowmaker clip several times, it has even
> dragged icons off the dock and thrown them away) 
> the pointer usually ends up in the upper right corner of the screen
> but it jumps around so fast i can only see where it has been by where
> menus pop up and windows get closed etc.  it is exceedingly annoying.
> i have tried disabling gpm, with no effect, furthermore this problem
> DOES occur in gpm without X and X without gpm, and with both running.  
> i have also tried 3 seperate mice, 2 three button, one 2 button. all
> exhibit this problem.
> the mouse only starts going into these `fits' when i use it, it never
> does this when the mouse is sitting idle. 
> it appears to go into these fits more often when i move the mouse
> faster, but moving the mouse at all (even slowly) still triggers it
> (just not quite as often) 
> X and gpm are configured for ps/2 mouse at /dev/mouse (symlink to
> /dev/psaux) i am using the same configuration on two other intel
> systems with no such troubles. 
> here is my gpm.conf, but note that i have disabled GPM and still had
> these problems in X:
> device=/dev/mouse
> responsiveness=15
> repeat_type=
> type=ps2
> append="-3 -a 3 -d 5 -l \"a-zA-Z0-9_.:~/\300-\326\330-\366\370-\377\""
> and here is my X config:
> Section "Pointer"
>    Protocol        "PS/2"
>    Device          "/dev/mouse"
>    Resolution      100
>    Buttons         3
> EndSection
> the 2 seperate mice were all different brands, the one i am using now
> is a 3 button Logitech PS/2.  
> i am at a loss, i have NEVER seen anything like this before, any ideas?
> -- 
> Ethan Benson
> http://www.alaska.net/~erbenson/

It sounds like either:
  - Wrong mouse type (maybe, try type mman for gpm / Mouseman or
    MouseManPlusPS/2 in XF86Config); or
  - IRQ or I/O conflict: perhaps you have two devices on IRQ 12 (or
    wherever your PS/2 post is located), and you're waking the wrong one up?

John P.
http://www.mdt.net.au/~john Debian Linux admin & support:technical services

Reply to: