[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Getting apache, PHP3, and PostgreSQL working together.



In article <cistron.20000718091722.A31630@bpl.on.ca>, Andrew Sullivan wrote:
>On Tue, Jul 18, 2000 at 05:31:15AM +0200, Remco Rijnders wrote:
>
>> So now with the cause pinned down, what can I do to fix this? I'd like
>> to run potato on this machine but really need version 7.* of
>> postgreSQL because of the foreign key support. Would upgrading just
>> the php3-pgsql package work, or would I then also need to upgrade
>> apache and all other things?
>
>The PHP3 packages from woody seem to work fine.  If you upgrade them,
>though, you'll get an upgraded apache, too.  And apache-ssl from woody
>conflicts with ssh, so if you need ssh, you can't have apache-ssl for now.
>
>You could compile the potato version of PHP against postgres 7.  That's what
>I did.  Just add a sources line to your sources.list.

I managed to solve the problem (thanks to your pointer earlier). In
the end I have downloaded php3-pgsql, php3 and apache-common from
woody. All other packages I could keep at the potato version,
including the main apache package.

The program I needed this for now works like a champ :) A thank you to
you and everyone else who attempted to help me. It is very much
appreciated.

Sincerely,

-- 
Remco Rijnders, ICQ: 760542 | Linux adanidas 2.2.14 is up 51 days,  8:52
http://www.starchat.net/    | Reporter: Mr Gandhi, what do you think of
Phone:    (+31) 70 3467809  |           Western Civilization?
Cellular: (+31) 6 22091723  | Gandhi:   I think it would be a good idea.



Reply to: