[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: unable to unmount

Title: RE: unable to unmount

Your problem is that you exported the CDROM with nfsd, and thus nfsd is still accessing it, even if nobody accesses your machine through nfs.

Just comment the line which exports your CDROM in /etc/exports, then issue "exportfs -ua", then "exportfs -a" .
This should unexport your CDROM, and allow you to unmount it, locally.


-----Original Message-----
From: Ragga Muffin [mailto:ragga@pyxis23.ec.t.kanazawa-u.ac.jp]
Sent: Thursday, July 13, 2000 10:56 PM
To: suresh@mycampus.com; sudhas@md3.vsnl.net.in
Cc: debian-user@lists.debian.org
Subject: Re: unable to unmount

"Suresh Kumar. R" <sudhas@md3.vsnl.net.in> wrote

> If I mount a cdrom and nfs mount it on some other machines, even after
> the other machine is switched off, I am unable to umount the cdrom
Please elaborate.
Do you mean you just shutdown the other machine ? Or that you umount the
cdrom ?

> from the server. I am using potato. I am forced to reboot the machine
> to get the cdrom out. I tried fuser but no use

This shouldn't be necessary. The problem is with nfs semantics and the
linux implementation (fstab + /proc).
If the cdrom is NOT mounted by ANYBODY then you should be able to umount
it on your end and get it out.

Other than that you can try to shutdown nfsd (don't count on that, I haven't
tried it)

> Any suggestions ?

Inform the other parties that they don't forget to umount the cdrom after
use ?  ;)


Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: