[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

--exclude behavior in tar seems to have changed


I always install Debian in one big ugly partition for convenience' sake.
Perhaps not the recommended method, but that's the way I do it.

Whenever I wanted to make a big tarball image of my current installation,
I always would log in as root, cd to /, and submit the following command:

# tar --same-owner -czpvf /syjet/debmain.tgz --exclude=tmp/*
--exclude=proc/* --exclude=syjet/* *

This would create an image on my syjet without including the junk in /tmp
or /proc, or the new image itself.  I have done this far too many times to
count over the past 2 or 3 years, and it has always worked and proved very
convenient for me.

I recently upgraded to potato and it seems this no longer works.  I just
tried to do a backup, and all the files below the directories following
the --exclude command now get included.  /tmp and /proc are bad enough,
but to include the partially created debmain.tgz from /syjet in
debmain.tgz would very obviously be ridiculous.  --exclude=/proc/*
doesn't work, either.

I re-read the manpage for tar, and it says:

--exclude FILE
              exclude file FILE

I thought that perhaps the equals sign had become unnecessary, so I tried
it without, and all it did was tar up the /proc directory.

May I ask why the behavior of the --exclude command has changed?  Can
someone suggest a remedy for my situation?


Matthew Thompson       http://mattyt.net
mattyt@oz.net          http://www.oz.net/~mattyt
--Someday, I'll have a web page.--

Reply to: