[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: make problems

 In answer to your questions no, I did not run ./configure in my own directory 
I just downloaded a tar.gz file into the new a directory in the new partition 
(since I no longer have any diskspace in my root partion containing my home 
directories) symlinked to my home directory. e.g. ln -s /mnt/ext/hda7/foo 
/home/user/foo. that didd;nt work so I also created another symlink ln -s 
/home/user/foo /mnt/ext/hda7/foo to maybe try to make it work but still to no 
avail. if I executed make from the root partition all goes well so I think 
maybe I am symlinking the wrong directories? that is why make does'nt execute 
from the new partition? if so, what can I do abt this?

> Joseph de los Santos wrote:
> > 
> > however, when I try to run make from that new partition I get this error:
> Let me guess:  did you run ./configure in your home directory, then
> mv the files to your working space on your new partition?
> > make -C src/ptlib/unix both ; make -C tools/asnparser both ;
> > make[1]: Entering directory `/mnt/ext/pwlib/src/ptlib/unix'
> OK... make will look in src/ptlib/unix for the Makefile,
> > Makefile:209: /home/jhou/pwlib/make/unix.mak: No such file or directory
> What does line 209 of src/ptlib/unix/Makefile have in it?
> I'm wondering if there's some $HOME/src/pwlib/make/unix.mak, or some
> variant.
> > grep: /home/jhou/pwlib/version.h: No such file or directory
> > ...
> > make: *** [both] Error 2
> > 
> > this may have to do with symlinks but I am really not sure.
> What symlinks do you have set up?
> > also Tried to make
> > as root but still get the same error (except for the directory /home/* it's
> > changed to /root/pwlib/blah...
> This strengthens my suspicion of some derivation of $HOME to get
> your working directory.  Maybe you should (from $HOME)
> ln -s /mnt/export/pwlib pwlib, then cd pwlib, and try your make -C ...
> -- 
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: