[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Sound problem (alsa / esound)


  I have enlightenment  0.16.4-1 on a woody system; I'm using an old
  SoundBlaster 16 (remember those which came with an IDE interface so
  you could plug the CD-ROM drive?).
  I had no sound problems until an upgrade I did yesterday: for some
  reason (I'm not sure if I did select additional packages or not, I
  thought I just did an apt-get upgrade), alsa seems to be

  During the installation of the packages yesterday, the alsaconf
  script was called...

  And my /etc/modules file now has several "alias snd-card-xx"

  When I boot, this is what I get:

sb Soundblaster audio driver Copyright (C) by Hannu Savolainen 1993-1996
sb: No ISAPnP cards found, trying standard ones...
SB 4.13 detected OK (220)

(so the sound card was detected)

But later in the boot process, I also get lots of messages like:

/etc/rc2.d/S20alsa: alias: snd-slot-XX not found
/etc/rc2.d/S20alsa: alias: snd-card-XX not found
/etc/rc2.d/S20alsa: alias: snd-service-0-0 not found
/etc/rc2.d/S20alsa: alias: snd-mixer-oss not found

(These are not shown when I call dmesg, I had to press ctrl-S and copy
them during the boot process)

And when I start enlightenment, it complains about not being ble to
communicate with esound... Also, I can't use the sound device (it's
lwys busy).

I do not have the package "esound" installed, but I *do* have
"esound-alsa", version 0.2.18-2 (I just checked) 

What could have happened? 

I tried calling alsaconf, and it shows me a list of soundcards (so I
suppose it didn't detect the soundblaster automatically)... I can see:


And the others options are PnP and PCI cards (so I suppose they
wouldn't work).
I have tried choosing SoundBlaster_1.0, but it didn't work.

Does anyone have any idea of what i have to do to get this working

Any help would be greatly appreciated.


Jeronimo Pellegrini
Institute of Computing - Unicamp - Brazil
mailto:jeronimo@dcc.unicamp.br    mailto:pellegrini@iname.com

Reply to: