[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: MST7MDT timezone broken?

On Wed, Apr 05, 2000 at 06:58:25AM -0500, John Hasler wrote:
> Bruce Sass writes:
> > MDT didn't kick in over here until I manually ran tzconfig.  I'm running
> > Potato, installed from bf-2.2.7 (libc6-2.1.2?), upgraded to
> > libc6-2.1.3-2.
> I've got 2.1.3-7 on this box.
> -- 
> John Hasler
> john@dhh.gt.org (John Hasler)
> Dancing Horse Hill
> Elmwood, WI

I also have libc6 2.1.3-7 (I was 'apt-get dist-upgrade' up-to-date
before the time-change weekend arrived).  And I had the problem with
EST5EDT, though not when I experimentally switched to America/New_York.
When I then reset to EST5EDT using tzconfig the problem returned
(date reported EST and 1 hour off).   On a hunch I manually copied
/usr/share/zoneinfo/EST5EDT to /etc/localtime (instead of the version
installed by tzconfig, which based on file size and diff results seemed
to be /usr/share/zoneinfo/SystemV/EST5EDT).  Then date reported the
right time zone (EDT) and time.  I had to stop/start cron, etc.  Then all
was well.  I then tried tzconfig again (and it broke the system), and then
yet again manually fixed it.  This last experiment was not to cause myself
more trouble, but just because I couldn't believe what I was seeing.

- MikeT

Michael E. Touloumtzis		mailto:toumi01@ca.com	-or-
Ingres Product Development	mailto:Michael.Touloumtzis@ca.com
Computer Associates International

Reply to: