[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Error Compiling kdenetwork-1.1.2

Following is a message I posted to the KDE User listserv a few days ago.
Stephan Kulow, developer of the kdenetwork package replied that he didn't know
what was causing the compile to terminate but did note that libdl was broken;
that I should have libdl.so instead of libdl.a. I'm running slink with a kernel
built from 2.2.14 source. I did download and install the binutils in frozen but
still get the same compile error. Isn't the linker in binutils? Any other
suggestions as to why kdenetwork isn't compiling. As noteb, kdenetwork is the
last module I tried compiling; all others compiled and installed with no
problems. And, KDE runs, but, of course, I dont' have kppp and kmail--two
programs most important to me on my laptop. Thanks for any advice...Bill

----------  Forwarded Message  ----------
Subject: Error Compiling kdenetwork-1.1.2
Date: Wed, 22 Mar 2000 17:37:17 -0600
From: Bill Caskey <wcaskey@worldnet.att.net>

I'm running Debian 2.1 (CD from McCarty's book) with a customized kernel I built
from 2.2.14 source. I compiled and installed all of KDE with kdenetwork being
the last module to compile.  After some half-hour or so of compiling, the
process terminates while (apparently) linking ksirc. The following lines
are the error messages generated. Can anyone help resolve the problem or
point me to documentation that will? Thanks.

/usr/bin/../lib/libdl.a(dlsym.o): In function 'doit.2':
dlsym.o(.text+0x22): undefined reference to '_dl_default_scope'
dlsym.o(.text+0x4c): undefined reference to '_dl_default_scope'
collect2: ld returned 1 exit status
make[3]: *** [ksirc] Error 1
make[3]: Leaving directory '/usr/src/kdenetwork-1.1.2/ksirc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory '/usr/src/kdenetwork-1.1.2/ksirc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory '/usr/src/kdenetwork-1.1.2'
make: *** [all-recursive-am] Error 2

--Bill Caskey

Bill Caskey

Reply to: