[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unidentified subject!

Quoting Lars Sander-Green (lars_in_russia@hotmail.com):
> I recently installed the most recent version of the Debian base system on an 
> old 486 (with a clean system) from floppy disks. Everything seemed to be 
> working fine and the base was installed, but when I tried to boot it from 
> the HD it returned only the message LI and then froze.

This is usually a geometry problem - there are more details in the
LILO documentation. You might try adding the linear option to
lilo.conf and rerunning lilo.

My experience leads me to doubt that there's such a thing as a "clean
system". I had two identical hardware systems that behaved very
differently with because one of the disks had been temporarily
installed in a different machine, and it had remembered some sort of
"block mode" that had been set there, which caused it to use a
different geometry in linux.

> I managed to boot 
> from the rescue disk and re-installed because I couldn't figure out the 
> problem. After the second instalation nothing was improved; in fact, the 
> rescue disk now returns LI.

I didn't know the rescue disk used lilo. Are you sure it's not still
trying the hard disk (cmos setting)? Does the floppy light come on
(discounting the "floppy seek at boot" that many BIOSes perform)?

> I have tried three different disks and numerous 
> reformats, but the disk refuses to boot. Althoug I'm not sure, the fact that 
> the system claimed my root sector was set to read-only and wouldn't let me 
> change it to writeable may have something to do with the no-boot from the 
> HD, but it doesn't explain the no-boot from the rescue disk.

Well it's possible to set boot sector virus protection in some
BIOSes and yours might be one.

> Any help, 
> either to succesfully boot the system or to completely re-install it, would 
> be appreciated.

It's not generally profitable to keep reinstalling over unless you
make changes (and note them down). The way I got my disk to "forget"
that it had been in a more modern system was to re-FDISK it in dos,
including the FDISK /MBR command after creating one single DOS
partition. I'm sure there are tuning programs that could have achieved
the same ends but it's not an area of linux I've used. But this also
had the effect of unsetting the "block mode" on the disk so that the
two identical disks were logically identical (bar serial no.) again.
Then I installed linux with no problem.


Email:  d.wright@open.ac.uk   Tel: +44 1908 653 739  Fax: +44 1908 655 151
Snail:  David Wright, Earth Science Dept., Milton Keynes, England, MK7 6AA
Disclaimer:   These addresses are only for reaching me, and do not signify
official stationery. Views expressed here are either my own or plagiarised.

Reply to: