[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Samba server connection from NT WS4 without password + MC only runs as root?

AD1: I run a Linux machine to serve NT Workstations with some common disk
area. It works just fine, we can connect to the server, but it's too good.
Because if I connect to the Samba server from a workstation, I can make
several connections with the name of the other users without asking to
give their password. If I brake all the connections, at the next connection
I have to give the password again.

I use Debian Potato with kernel version 2.2.13
Samba , samba-common 2.0.6-3

My smb.conf contains these more important lines:
security = user
workgroup = <the same as on the NT Workstations>
encrypt passwords = yes
wins support = no
wins server = <the same as on the NT Workstations>
os level = 0
domain master = no
local master = no
preferred master = no
dns proxy = yes
comment = sajat konyvtar
browsable = no
read only = no

Is this a config problem or a security hole?

AD2: I can run the Midnight Commander on this machine only as root.
If I try to use it on the console it gives an error message:
Floating point exception, if with ssh from another machine (PuTTY.EXE):
Segmentation fault.
The attribs of the MC are as follows: rwxr-xr-x root root.
As I use it as root it just works fine. I tried to delete the .mc dir of the
user, but it didn't help.
What's the problem?

Thanks in advance,
                         Mr. QB

Reply to: