[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can't print from Gimp

Hi all:

I have a problem printing from Gimp 1.1.14 to a "postscript"
printer. My printer doesn't even start printing, although "lpq" shows
the job in the que, and says that it's printing.

I tried printing to a .ps file, and then I can successfully view it
with "gv" and "xv". But if I try "lpr file.ps", then, again, nothing

I tried fiddling with postscript levels in Gimp, and that didn't help.

All other applications (such as netscape, for example), print to the
same printer w/o any problems.

FWIW, the printer itself is an HP DeskJet 697c, and I use it with
"hpdj" filter from ghostscript. My printcap looks like this:

,----[ printcap ]
| lp|lp1|HP Deskjet 697C Draft:\
| 	  :lp=/dev/lp0:sd=/var/spool/lpd/lp1:\
| 	  :sh:pw#80:pl#66:px#1440:mx#0:\
| 	  :if=/etc/hpdj/hpdj-draft:\
| 	  :af=/var/log/lp-acct:lf=/var/log/lp-errs:
| lp2|HP Deskjet 697c Normal:\
| 	  :lp=/dev/lp0:sd=/var/spool/lpd/lp2:\
| 	  :sh:pw#80:pl#66:px#1440:mx#0:\
| 	  :if=/etc/hpdj/hpdj-normal:\
| 	  :af=/var/log/lp-acct:lf=/var/log/lp-errs:
| lp3|HP Deskjet 697c Best:\
| 	  :lp=/dev/lp0:sd=/var/spool/lpd/lp3:\
| 	  :sh:pw#80:pl#66:px#1440:mx#0:\
| 	  :if=/etc/hpdj/hpdj-best:\
| 	  :af=/var/log/lp-acct:lf=/var/log/lp-errs:
There's nothing at all in /var/log/lp-errs.

I can print using Gimp's own HP DJ driver, but I really don't like
that driver, for it's very inky.

Any help highly appreciated!
Arcady Genkin                                 http://www.thpoon.com
Nostalgia isn't what it used to be.

Reply to: