[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

JDK says can't open /proc/xxxxx

I recently installed jdk onto my potato box - one of my classes this
semester is programming in Java.  The problem I am having is that every
time I try to run javac to do the byte-compile I get the message:
Cannot open /proc/04505 for GC
The number here   ^^^^^ is different every time.  I even tried doing the
javac command as root and got the same message, except for the number.
What has me the most confused is I got it to work once.  But then it hasn't
worked again.

I found that these two environment variables are needed - I'm really not
sure about the CLASSPATH though.  What documentation there is says that
it's a variable that's needed, but says nothing about what to put into

HAL9000:~/cs136$ dpkg -l jdk*
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name           Version        Description
un  jdk-shared     <none>         (no description available)
un  jdk-static     <none>         (no description available)
ii  jdk1.1         1.1.7v3-2      JDK 1.1.x (Java Development Kit) - Runtime o
ii  jdk1.1-dev     1.1.7v3-2      JDK 1.1.x (Java Development Kit)
ii  jdk1.1-native  1.1.7v3-2      JDK 1.1.x Runtime - native threads extension
ii  jdk1.1-native- 1.1.7v3-2      JDK 1.1.x - native threads extensions
un  jdk1.1-runtime <none>         (no description available)

Apparently the jdk-runtime package has been replaced by jdk1.1  What about
the jdk-shared and jdk-static packages?  I couldn't find any mention of either
one in the Packages files in /var/state/apt/lists so I'm presuming they too
have been superceeded.

My system here is potato - did an apt-get update;apt-get dist-upgrade two
or three days ago.  I'm runing kernel 2.2.13  Does anyone have any
Mike Werner  KA8YSD           |  "Where do you want to go today?"
ICQ# 12934898                 |  "As far from Redmond as possible!"
'91 GS500E                    |
Morgantown WV                 |  Only dead fish go with the flow.

Reply to: