[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

samba - dissapearing files/directories

ive been workin on this samba server for the past 6 hours or so..and am
running out of ideas.

the server works fine from a linux machine using smbclient but it goes all
weird when i use win9x.  i have 3 shares:


Applications is meant to be writable by admins only, readable by everyone,
stuff is meant to be readable/writable by everyone, and of course $HOME is
a user's home dir(not that i need that sure)

what happens is, i login, see the directories..can copy all day long to
them, files show up, everything is happy..but when i logout and back in
again(even with the same account) the files are GONE.  they aren't gone
from the server just win9x doesnt show them in explorer
anymore.  smbclient shows them as being all there as does viewing them in
the shell, i set the debug level to as high as 5 and the smb log didnt
show anything that may of looked like an error.

this is the config:

        path = /mnt/stuff2/stuff
        valid users =
        read list = martin,walter,shane
        write list = 
        read only = No
        directory mask = 0775
        force directory mode = 0775
        guest ok = Yes

i am using user mapping to map the users to their "real" Win* usernames,
the logs reflect the mapping as working, and am using a NT machine to do
password auth(also works fine)  i have tried so much stuff now im
overlapping in ideas and am getting lost.  _currently_ the unix
permissions for that share is 777 owned by samba.samba and the directory
is sgid. currently i am using the user 'nate' to test it.  i can go
directly to the directories if i use start|run and enter
\\machinename\\sharename\directory but the files inside there don't
show.  the 'nate' user is on the admin list and samba shows it as giving
me root privlidges but still can't see any files, correction..there is one
file i copied over earlier today(about 50 re configurations ago maybe).

i have tried force user/groups i have tried guest access i have tried
making everything 770 and 775 ...but what confuses me the most is how does
smbclient work when win9x does not?  also is there a way to bypass local
user auth? to rely totally on the(ack) nt box for passwords, i am using
user mapping and security = server , but it wont allow any users unless
they exist in /etc/passwd. i set this machine up with 45gb of space so i
could share it out for my dept's use, would be nice to use it!  ive used
samba in the past, but have never had a configuration such as this
before(at home i use samba 2.1 prealpha with PDC support and all works
perfectly, but i also have only 2 user accounts, at most 2 clients, and no
username mapping).

I have been using SWAT to configure it. using samba 2.05a from slink.

ideas? i have a massive headache.


----------------------------------------[mailto:aphro@aphroland.org ]--
   Vice President Network Operations       http://www.firetrail.com/
  Firetrail Internet Services Limited      http://www.aphroland.org/
       Everett, WA 425-348-7336            http://www.linuxpowered.net/
            Powered By:                    http://comedy.aphroland.org/
    Debian 2.1 Linux 2.0.36 SMP            http://yahoo.aphroland.org/
-----------------------------------------[mailto:aphro@netquest.net ]--
1:39pm up 146 days, 1:39, 1 user, load average: 0.25, 0.36, 0.33

Reply to: