[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

System hangs while using vcstime

I have not submitted this as a bug, because I'm not yet sure what's
going on.  But I figured I'd post this to see if anyone has had
similar experience, or has any ideas.

Earlier today, as root, I ran `vcstime'.  This program causes the time
of day to appear in the corner of all the text-mode consoles.  Kinda
handy.  However, probably within an hour of starting the program, I
was switching from the first text console to my X session by pressing
Alt+F7, and the system hung.  By "hung", I mean that pressing keys on
the keyboard had no apparant effect -- pressing the NumLock key, for
example, didn't cause the little light on my keyboard to light up, as
it usually does.  I couldn't even `ping' the system from another
system on the same LAN.  (The screen was white, and appeared to be in
graphics mode.)  So I rebooted.

After the machine came up, I ran `vcstime' again; again within an hour
or so, after hitting Alt+F7, the system hung.  Same symptoms.

So now I'm not running `vcstime' :)

Now, I'm not entirely sure that vcstime is to blame, because I am alas
utterly ignorant about how to debug that kind of hang.  But I do of
course suspect `vcstime', because I've been using the same kernel for
months, and I switch from a text-mode console to X, and back, dozens
of times a day, and have never had this happen before.

Anyway, does this sound like enough info for me to open a bug against
console-tools?  Or should I do some more investigation first -- and if
so, any suggestions on how to investigate?


Reply to: