[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: char-major-5

Michael Heyes wrote:
>I checked to make sure, and I did have "standard/generic (dump) serial support"
>compiled into the kernel, but it was compiled in and not a module. I tried
>compiling it as a module, which generated the serial.o file you mentioned below
>in /lib/modules/2.2.13/misc, and the message/problem went away. So, is this a
>bug? If support is compiled in the kernel, why would it try to load a module?
>One other char-major problem. When I start my ppp session with pon, I get a
>"Can't locate module char-major-108". The session works ok. I tried compiling
>ppp as a module instead of in the kernel (it worked with char-major-5), but that
>didn't solve anything. I did modprobe -c, but the I could only find "alias
>char-major-107 3dfx", no -108 anywhere.
>Do you know what char-major-108 is supposed to be? Is it part of ppp?

Invariably, the easiest way to find out the answers to this class of
questions is to look in /usr/src/linux/Documentation/devices.txt. There,
you'll find that character major 108 minor 0 is indeed /dev/ppp.

Colin Watson                                           [cjw44@cam.ac.uk]
Trinity College, Cambridge, and Computer Science         [riva.ucam.org]

Reply to: