[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ipmasq_3.2.5 breaks nameserver lookups



Curt Daugaard (cld@mcs.net) wrote:

> The subject says it all.  I've gone through the docs, but
> since the out-of-the-box config at least appears to have
> broken a pretty average dialup ppp setup, I'm wondering
> if others have run into the same problem and would be
> willing to tell what fixed it.

The slink ipmasq package *would not* work for me.  I uninstalled it, and
then manually added the lines I wanted to the startup scripts:

        case "`uname -r`" in
          2.1*|2.2.*)
                echo 1 >/proc/sys/net/ipv4/ip_forward
                ipchains -P forward ACCEPT
                ipchains -A forward -j MASQ -s 192.168.2.0/24 -d 0.0.0.0/0
                ;;
          2.0*)
                ipfwadm -F -p deny
                ipfwadm -F -a m -S 192.168.2.0/24 -D 0.0.0.0/0
                ;;
        esac

(Not perfect, since the switch to ipchains isn't cleanly "2.1.*", but
this worked for the set of kernels I was using at the time....)

-- 
Greg Wooledge                    | "Truth belongs to everybody."
wooledge@kellnet.com             |   Red Hot Chili Peppers,
http://www.kellnet.com/wooledge/ |

Attachment: pgpW_f5nRJXKY.pgp
Description: PGP signature


Reply to: