[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

apt "freezing" when retireving package lists


I have a problem with apt 0.3.10slink11.

Since I upgraded from slink r0 to r3, it doesn't retrieve package lists

I tried using http and ftp uri's in sources.list and apt always stops
when it should retrieve the packages.

It obviously parses the files, connects to the server and then stops,
waiting for something to happen.

wind:~# apt-get update
Connecting to ftp.si.debian.org
Logging in
0% [Query]

And it waits here until i kill it with ctrl+c.

The machine is a sparcstation 2, if that helps. I am also behind a
firewall, which stops passive ftp, but it shouldn't be a problem with
http (also tried, same result).

Here is my sources.list:

#deb http://http.us.debian.org/debian stable main contrib non-free
#deb http://non-us.debian.org/debian-non-US stable non-US

deb ftp://ftp.si.debian.org/debian stable main contrib non-free
deb ftp://ftp.si.debian.org/debian-non-US stable non-US

I also tried the first two servers, no luck.

If there is anything I forgot to mention, please tell me.


The road to success is always under construction.

Reply to: