[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Emacs20 install error



On Sat, Oct 16, 1999 at 01:55:41PM -0500, Carl Greco wrote:
> I am attempting to replace emacs-19.34 with emacs-20.3 on a Slink
> system with the following steps:
> 
> 1) Remove emacs19:  dpkg -r emacs19
>    [leaving emacsen-common (1.4.8) installed]
> 
> 2) Install emacs:  apt-get install emacs20
> 
>    Emacs installs but fails to configure with the following error
>    message: 
> 
>    Cannot open load file: debian-rundir
>    emacs-install: /usr/lib/emacsen-common/packages/install/emacsen-common emacs20 failed at /usr/lib/emacsen-common/emacs-install line 28.
>    dpkg: error processing emacs20 (--configure):
>    subprocess post-installation script returned error exit status 29
>    Errors were encountered while processing:
>    emacs20
>    E: Sub-process returned an error code
> 
> 
> Also attempted to install emacs20 with dpkg with similar results.
> Could not find "debian-rundir" on disk or distribution CD.  Where do I
> get "debian-rundir"?
> 

I'm not sure I can be much help but as no one else has replied...  On my
system where I have both emacs19 and emacs20 installed and working I get

$ locate debian-rundir
/usr/share/emacs/19.34/lisp/debian-rundir.el
/usr/share/emacs/19.34/lisp/debian-rundir.elc

and

$ dpkg -L emacs20 |grep debian-rundir
$ 

I had a quick scan of the install scripts for emacs20 (package version
20.3-7) in /var/lib/dpkg/info and saw no mention of debian-rundir
which is kinda odd, so what package version are you trying to install?
I remember I had problems when first installing Debian (hamm) and had
to install emacs19 to get emacs20 to install properly.  Maybe you
should try installing emacs20 first and *then* remove emacs19.  Either
way if emacs20 needs emacs19 stuff to install it's a bug and you
should probably file a bug report.

Probably not much help but there you go...

Ian.


Reply to: