[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libc 2.0->2.1: apt-get ftp problem

I have not been on the list for awhile so forgive any redundancy. I checked 
the mail archives and found no answers and only one similar complaint.

I worked up the nerve to upgrade my slink to libc 2.1 with the goal of playing 
with gnome. I used (for the first time) apt-get with an ftp entry in
the sources.list and did a "apt-get install libc6".

It worked well and the system seemed fine. apt-get included
(via depenndency) stdc++, apt, and some others (5-6 total).

Every subsequent ftp retrieval via apt-get complained that it had failed
with a size mismatch. The retrieved packages seemed fine however, and 
installed successfully without complaint.

Also, at some point, "apt-get --no-download install orbit" (for example)
failed with a complaint about "unable to handle media swap". This is the 
one symptom I found reported a recent deb-user archive, but no answer.

It is with hindsight that I'm guessing that the real problem started after
the intial libc upgrade (I ignored the size complaint since it seemed
to be erroneous, but eventually got stopped by the "media swap" 

My plan was to go back to slink, do the libc upgrade, and look more
carefully for the media swap error. But since it  appears that apt-get
won't downgrade (?), I am writing this to decide if I really want to 
to the dpkg 2-step that will be required to remove the (several) gnome packages I had installed and get back to my previous state.

Does anyone have hints, ideas, experience that might be relevant?



Reply to: