[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

large hard disks (again)

I have posted this before, how to fdisk a > 8.4gb
drive.  Problem was that with slink fdisk saw only
1024 cy, 255h, 63s for a total of 8.4gb.  If I booted
a RedHat 6.0 or Mandrake 6.0 CD (also stormix) their
partition utilities (fdisk, disk druid, etc) would
report the correct number of cyl's (2100) to give a
17.2gb total disk size. 

After partitioning with Stormix I stopped the install,
and booted my slink cd and then installed slink
(skipping the partition step, which was already done).
 This worked.  Now if I run fdisk, it still reports
the wrong(?) number of cyl's but does show the correct
partition sizes (p command).  It also complains about
different logical and physical starting and/or ending
cyl numbers for the last two partitions on the disk. 
However if I go to expert mode (x) and change the
number of cylinders (c) to 2100, the p command now
gives the exact same printout as fdisk under Mandrake
or Redhat fdisk.  So...why does fdisk get the correct
size info from the kernel under Mandrake or Redhat? 
Can it be a difference between the 2.0.36 kernel and
the 2.2 series?  Or is it a later version of fdisk
itself (BTW cfdisk and sfdisk behave the same way...)
I now think the difference is in the 2.2 kernel.
Any ideas?  I now know I can partition under debian by
giving fdisk the correct final cyl number.  But I
still had to use Mandrake fdisk to find this number!

Amateur Radio, when all else fails!


Debian Gnu Linux, Live Free or .....

Do You Yahoo!?
Bid and sell for free at http://auctions.yahoo.com

Reply to: