[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with ISA Kingston ethernet card



On Fri, Sep 10, 1999 at 04:33:51AM +0200, shaul wrote:
> > 
> > The card is a KNE2021LC, ISA, made by Kingston. I use the normal NE2000 ISA
> > drivers. The card appears to be detected correctly but fails to work if I try
> > to transmit anything on it. 
> 
> I guess you did it but it never hurts to make sure: Are the modules get 
> loaded/compiled into the kernel ? Are the configurations files correct ?
> 

Yes, thats what I meant with the card being detected:

'modprobe ne io=0x300 irq=3' gives me something like:
NE*000 ethercard probe at 0x300: 52 54 4c 1c 84 2e
eth1: NE2000 found at 0x300, using IRQ 3.

then ifconfig eth1 192.168.1.1 seems to work ok, but the transmission itself
does not work, like if the cable was damaged (but the cable is good, I checked
with the other card).

> >There is no error message. I tried changing IRQ,
> > but that did not work. I used the test programs provided by Kingston and they
> > ran fine. The card runs fine under windows too. I tried on two different linux
> > pc and neither could use it. Any idea?
> > 
> 
> I have an odd problem with an NE2000 ISA card. It also does not do it job after rebooting the machine unless I unplug the cable and then restore it back. It is like this action triggers the card to start do its network job. Perhaps this is your problem too ? Has anyone else encounters it and/or knows/have suggestions how it can be solved ? 
> 

Did not do any good. I will try changing IRQ again... thats the most likely
cause for this misbehaviour I think. Btw, when I said it worked for windows,
thats not on the same computer (that one only has linux). I will try again on
a windoze pc just to check the card has not fried in the meantime. I will also
try to get the NE2000 test for linux.

Thanks,
-Lex

Attachment: pgpkwDjvpLud9.pgp
Description: PGP signature


Reply to: