[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Help--potato upgrade flakey with apt-get/dselect


On Thu, 2 Sep 1999 kaynjay@igalaxy.net wrote:

> I apologize up front for the length of this post, but am trying to max
> the info for brave souls who may be able to help me...
> An upgrade initially using apt-get then finished with deselect has
> left an unknown number of packages possibly not upgraded.  
> Slink-->potato, BTW.
> The long story:  (the big questions are listed at the end, FWIW)
> An upgrade which ran all night/day has apparently not updated all
> packages.  After initial download-only, I reran apt-get dist-upgrade
> and most packages installed seemingly with no problems.  Then I noted
> flakey operation of gnome under X, and somehow surmised that the
> system had been unpacked but not configured.  I didn't know about
> "dpkg --configure -a" at the time, but got the idea of using deselect.

If some package couldn't be downloaded, because of a timeout or something,
this will cause trouble with installing other packages as well. Also, it
could be that apt-get isn't perfect, and tried upgrading package X before
package Y when Y needed to be first.

You'll want to note the errors reported, and if you can't figure them out
check the list archives.

> It updated the package lists via apt.  I looked at the list (full of
> U's) and decided to add the 2.2.10 kernel package.  In addition to its
> dependencies, others were noted for other packages.  I accepted them,
> as I have no way to tell the validity of the choices made.  Deselect
> got a newer version of the unstable lists as well, forcing a further
> download of 36 Mb.  Installation seemed to go well, with the
> unconfigured packages dropping to 2 from 200+.

Which 2?

> Attempted setup of the kernel package (which dselect never unpacked)
> failed at "make menuconfig" concerning ncurses.  I tried to remove the
> older ncurses3.4 package (since the latest was also installed), but
> dpkg balked.  That's when I discovered that sysutils and taper had not
> been upgraded, apparently.  I expect others are the same way.

You need the -dev package for the latest ncurses for make menuconfig...
It's only listed as a Suggests, so you probably missed it in the conflict
resolution screen.

> 1) Is there a way to get this to work?  Can I redo the apt-get with all the
> files I downloaded, and simply force every package to be redone??  I have a
> feeling that something weird happened when I went over to dselect.  

i don't think you need to, you just have to get those 2 fixed.

Also, you can eventually go through and remove some slink packages
(especially libs) that aren't needed under potato. Sometimes the package
is renamed between the two, so you get no notice that the old one isn't
needed anymore... The only problem is that it takes up disk space, so
don't feel you have to rush it.

> 2) And why didn't the dist-upgrade not configure things initially?  Would
> "dpkg --configure -a" be a better choice if it happened again?

"dpkg --configure -a" would be good to try. After doing that a few times,
note the error messages and take action to correct them.

> 3) How do I deal with the ncurses issue.  Are any of the potato deb's
> dependent on the older ncurses3.4?

See above.

> 4) perl-5.004 vs. perl-5.005 ???  Do I trash the former or not?  Dselect
> wouldn't let me remove it...  (something to do with those un-upgraded
> packages??)

Ah, the Great Perl Upgrade. Once you have your system completely potato,
you can remove perl-5.004 without much trouble. This may bring some of
those obsolete slink packages out of the woodwork, just look at the
dselect conflict resolution screen and see if you really want to keep any
that are to be removed... AFAICT, there's only one potato package that
hasn't made the Upgrade (netcdf-perl)

> Should the first step in dselect been to configure packages, without
> any of the other steps??

Wouldn't have hurt, but probably wouldn't have helped either.

- -- 
  finger for PGP public key.

Version: 2.6.3ia
Charset: noconv


Reply to: