[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Still can't get a DHCP address

Well, I'm still unable to get an IP address, using either dhcpcd or
dhclient under slink.

I'm using loadlin to boot the computer (LILO won't install on it).
I'm including (1) the contents of my loadlin param file.

(2) is a dump of dmesg. There's a number of errors in there (apache,
for example) I haven't gotten around to try to fix yet. From what
I can tell, it's recognizing both NICs correctly.

To get Linux to recognize the second NIC, I had to edit
/etc/network (3).

ifconfig -a (4) shows both NICs configured correctly, including IRQs
and addresses. I tried switching my LAN to eth1, and that worked, so
configuration should be OK. One strange thing is that if I run
ifconfig without the -a switch, eth1 does not show up.

When I run dhclient eth1, I get error messages (5) and still no IP
address on eth1.

dhcpcd also failed to get an IP address, but showed nothing in syslog.

Does anyone have any insight they want to share?


(1) linuxpar.1:

# this is an example commandline parameter file for LOADLIN
# You may have comments starting with "#" at any place
# comments end at end of a line
# any number of empty lines may be inserted.
# The contents are compacted by LOADLIN to produce an as small
# commandline as possible.
# For more commandline options see the file PARAMS.DOC.
# There can only be one parameter file and LOADLIN must be called as:
#   LOADLIN @param_file
# However, the parameters in param_file may be overwritten by
# (or appended to) those following the @param_file, e.g:
#   LOADLIN @param_file image=other_image root=/dev/other
                   # first value must be the filename of the Linux-kernel
                   # if this should be changed at load time,
                   # the keyword 'image=' must be used (see above)

-v              # verbose the actual params, but load anyway
#-t             # write debug output and stop.
#-d c:\dump     # write debug output to file c:\dump and stop.

vga=extended    # legal values are:
                # numeric:
                #   -3    ask
                #   -2    extended
                #   -1    normal
                #   0..9  as if entered on boot-prompt
                # symbolic:
                #   ask
                #   normal
                #   extended
                # However, starting with Linux-1.3.75 the code for
                # vga=has changed, to get the actual values for your
                # special video card, you should use 'ask' and remember
                # the values that were printed on screen.
                # See also linux/Documentation/svga.txt

root=/dev/hdb3  # the device which gets mounted as root FS
# root=201      # NOTE: the numeric device tokens are hexa !
# root=/dev/sda1
# ....

# rw

#initrd=..\initdisk.gz  # This file gets loaded as 'initial ramdisk'
                        # see initrd.txt for more

#noinitrd               # This keyword is usefull, if you wany get
                        # the 'initial ramdisk' loaded, but not
                        # processed at startup.
                        # It will remain as /dev/initrd.

# this can be used in /etc/rc to do some special work



(2) dmesg:

Linux version 2.2.6 (root@firemoth) (gcc version #5 SMP Mon Aug 16
20:13:55 EST 1999
mapped APIC to ffffe000 (00215000)
mapped IOAPIC to ffffd000 (00216000)
Detected 99720166 Hz processor.
Console: colour VGA+ 80x50
Calibrating delay loop... 39.73 BogoMIPS
Memory: 63364k/65536k available (808k kernel code, 416k reserved, 908k
data, 40k init)
Checking 386/387 coupling... OK, FPU using exception 16 error reporting.
Checking 'hlt' instruction... OK.
Intel Pentium with F0 0F bug - workaround enabled.
POSIX conformance testing by UNIFIX
per-CPU timeslice cutoff: 1.56 usecs.
CPU0: Intel Pentium 75 - 200 stepping 05
SMP motherboard not detected. Using dummy APIC emulation.
PCI: PCI BIOS revision 2.10 entry at 0xfc7d7
PCI: Using configuration type 1
PCI: Probing PCI hardware
Linux NET4.0 for Linux 2.2
Based upon Swansea University Computer Society NET3.039
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
Starting kswapd v 1.5
Detected PS/2 Mouse Port.
pty: 256 Unix98 ptys configured
CMD640: ignored by ide_scan_pci_device() (uses own driver)
ide0: buggy cmd640b interface on PCI (type1), config=0x5e
ide1: not serialized, secondary interface not cmd640
cmd640: drive0 timings/prefetch(off) preserved
cmd640: drive1 timings/prefetch(off) preserved
hda: Maxtor 71260 AT, ATA DISK drive
hdb: SAMSUNG WN316025A (1.6 GB), ATA DISK drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: Maxtor 71260 AT, 1204MB w/256kB Cache, CHS=612/64/63
hdb: SAMSUNG WN316025A (1.6 GB), 1536MB w/109kB Cache, CHS=3121/16/63
hdc: ATAPI 32X CD-ROM drive, 128kB Cache
Uniform CDROM driver Revision: 2.54
Partition check:
 hda: hda1
 hdb: [PTBL] [780/64/63] hdb1 hdb2 hdb3
VFS: Mounted root (ext2 filesystem) readonly.
Freeing unused kernel memory: 40k freed
Adding Swap: 66020k swap-space (priority -1)
eth0: 3c509 at 0x230 tag 1, 10baseT port, address  00 60 97 18 8a b3, IRQ 10.
3c509.c:1.16 (2.2) 2/3/98 becker@cesdis.gsfc.nasa.gov.
ne.c:v1.10 9/23/94 Donald Becker (becker@cesdis.gsfc.nasa.gov)
NE*000 ethercard probe at 0x240: 00 80 c8 ec 0a db
eth1: NE2000 found at 0x240, using IRQ 9.
Serial driver version 4.27 with no serial options enabled
ttyS00 at 0x03f8 (irq = 4) is a 16550A
ttyS01 at 0x02f8 (irq = 3) is a 16550A


(3) /etc/network

#! /bin/sh
modprobe ne
ifconfig lo
route add -net
ifconfig eth1 ${IPADDR} netmask ${NETMASK} broadcast ${BROADCAST}
route add -net ${NETWORK}
[ "${GATEWAY}" ] && route add default gw ${GATEWAY} metric 1


(4) ifconfig -a (before running dhclient)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          UP LOOPBACK RUNNING  MTU:3924  Metric:1
          RX packets:86 errors:0 dropped:0 overruns:0 frame:0
          TX packets:86 errors:0 dropped:0 overruns:0 carrier:0

eth0      Link encap:Ethernet  HWaddr 00:80:C8:EC:0A:DB
          inet addr:  Bcast:  Mask:
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Interrupt:9 Base address:0x240

eth1      Link encap:Ethernet  HWaddr 00:60:97:18:8A:B3
          unspec addr:[NONE SET]  Bcast:[NONE SET]  Mask:[NONE SET]
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          Interrupt:10 Base address:0x230


(5) dhclient output

SIOCSIFNETMASK: Cannot assign requested address
SIOCSIFBRDADDR: Cannot assign requested address
SIOCSIFNETMASK: Cannot assign requested address
SIOCSIFBRDADDR: Cannot assign requested address
eth1: not found


                This is what we do. This is who we are.
            Hail Eris! -><- Kallisti -><- All Hail Discordia!

Reply to: