[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: using AUI port of 3c529 (MCA) network card


I had a similar problem, but solved it in another quick & dirty way.
Instead if meddling with the module-parameters I simply took the 3Com
Utility-disk, which was delivered with the card, booted it and used
their setup-program to switch to the Coax-port and not go by autodetect.

It might be an unusual solution, but it works fine.

The utility/diagnostics-disk can be downloaded from 3Coms site also.


Matthew Munsey wrote:
> I've been unsuccessful in getting my 3Com 3c529 MCA Ethernet card to
> communicate with the network using the AUI port, although the 10baseT
> (twisted pair) connection with the card works fine.  The 3c529 is the MCA
> (IBM's proprietary microchannel architecture for the PS/2 and other
> machines) version of the 3c509 (same chipset), so I use the 3c509.o module
> that came with my Debian installation (Linux 2.0.36).  The 3c509.c file in
> the 2.0.36 source tree actually has MCA detection code for the 3c529,
> although I'm not sure that it's complete.
> To debug the problem, I've tried compiling the module myself from the
> 2.0.36 source tree, sometimes with certain modifications and also without
> any changes.  However, I have the problem that the newly compiled 3c509.o
> will not work at all with my network card, even though the one that came
> with Debian (supposedly 2.0.36) does work.  Is it possible that the 3c509.c
> source that was used in this version of Debian is different than the one in
> the 2.0.36 source tree I've been using to compile my own?  Does anyone know
> what version of 3c509.c is in this Debian distribution?
> When I insmod the correct 3c509.o module without any arguments (insmod
> 3c509), I get the following (note that the card identification on the first
> line comes directly from the MCA card and thus has nothing to with the
> module's detection mechanism):
> # insmod 3c509
> 3c509: found 3Com 3c529 EtherLink III (10baseT) at slot 3
> eth0: 3c509 at 0x200 tag 0, 10baseT port, address  00 20 af 99 a8 1e, IRQ 5.
> 3c509.c:1.16 2/3/98 becker@cesdis.gsfc.nasa.gov
> After this, I manually run /etc/init.d/network, and the card then works
> fine off the 10baseT port.
> [Note: The version of 3c509.c in the 2.0.36 source tree is also identified
> as v1.16 2/3/98, so it seems like it should be the same.]
> However, when I run the version that I compiled myself from the 2.0.36
> source tree, I get the following:
> # insmod 3c509
> /lib/modules/2.0.36/net/3c509.o: init_module: Device or resource busy
> If I subsequently replace the 3c509.o file with the correct module (the one
> that came with the Debian distribution), it then works as shown above.
> However, I want to enable the AUI port on the network card, so I use the
> xcvr option to set the transceiver port to 1 (AUI), but I get the same
> response from the module (which still claims that I am using the 10baseT
> port, as seen in the second line of output, where it should instead say AUI
> port):
> # insmod 3c509 xcvr=1
> 3c509: found 3Com 3c529 EtherLink III (10baseT) at slot 3
> eth0: 3c509 at 0x200 tag 0, 10baseT port, address  00 20 af 99 a8 1e, IRQ 5.
> 3c509.c:1.16 2/3/98 becker@cesdis.gsfc.nasa.gov
> I then run the /etc/init.d/network script as before, but I get no ping
> response from any hosts (including IPs on my local subnet).  If I then
> unplug the AUI connector and plug in the 10baseT cable, thinking that the
> program decided to use the 10baseT port as it claimed (ignoring my xcvr=1
> option), it still fails to work, and I am unable to use the network card
> until I reboot (because rmmod does not properly allow me to insmod again
> without the xcvr=1 option).
> Please cc: any responses to me, as the debian-user web archive only seems
> to store mail from the first few days of each month.
> Thanks for any advice or information on this setup and my difficulties.
> Matt
> --
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: