[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: problem with libgnomeui32 1.0.9-3

On Mon, Jun 07, 1999 at 11:47:08PM -0400, Stuart Ballard wrote:
> "Luis M. Garcia" wrote:
> > 
> > ""Raphaël\"@scuzzy@francemel.com"UNEXPECTED_DATA_AFTER_ADDRESS@.SYNTAX-ERROR,
> >  wrote:
> > >
> > > I have d/l gnome-apt with apt-get and it of course has d/l and installed
> > > some others package like libgnomeui32. But now, every gnome application
> > > tells me:
> > >  gnp: error in loading shared libraries: /usr/lib/libgnomeui.so.32: undefined symbol: gdk_imlib_get_cache_info
> > >
> > > I do have imlib installed. I've tried recompiling libgnomeui but it
> > > complained about a bad version of libz.I have libz.so.1.1.3 wich was
> > > with the slink I think
> > >
> > I had the same problem, and it was caused because the gdk-imlib1 package
> > was not updated during the gnome install (is this a bug in the dependencies?).
> I believe it is - I posted with it to the mailing list some time ago and
> was told that it wasn't a valid/useful bug report because I couldn't say
> exactly what package was missing what dependency. My thoughts on the
> most likely problem, and someone pointing out a flaw in my theory, can
> probably be found in the list archives. If other people are having the
> same problem, then it should probably be fixed.

In the last days, there were a significant number of posts in this list
referring to this problem, so I also think that it should be fixed.

> By the way, I should amend the comments I made at the time. I postulated
> that some package (I forget which) didn't depend on another; the reply
> pointed out that the dependency actually was there. My theory now is
> that the dependency didn't specify the correct version of the package (I
> remember it just named the package, not a specific version).

Looking at the "Depends" header in libgnomeui32 we can read:

Depends: libgnome32, gdk-imlib1, libaudiofile0, libc6, libesd0, [...]
We can see that the dependency is there, but you're right, the correct
version isn't specified, I think it should be somethink like 
gdk-imlib1 (>= 1.9.4), but I'm not sure.

Knowing this new data, sending that bug report is OK, IMHO. What do you

         Luis M. Garcia

Reply to: