[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

identd -- doesn't work in slink.

I have this really strange problem.  I had 1 main server running debian
2.0, and identd was fine. I upgraded it to debian 2.1 ..and it no longer
works. I removed it from inetd.conf and tried to run it at the command
line and i got something along the lines of

in.identd: getpeername(): Socket operation on non-socket

So..I went to 2 other Debian 2.1 systems and tried it..identd broken on
them as well.  I checked and re-checked /etc/services changing identd to
auth and back again trying to get it working.  I even copied the old
/etc/services and old identd and old inetd.conf from the 2.0 hdd to the
2.1 hdd ..same results.  So i went out onto freshmeat and grabbed identd
v2 which is what I am using on my slackware system..i got it to reply once
or twice but after that it no longer would.  i am allowing full access to
identd via hosts.allow and port 113 is not firewalled at all.

while identd is by no means critical it lets me go to a few more irc
servers that i would otehrwise not be able to access :)

I remember getting that socket error on another debian 2.0 system when i
tried to run telnet..but I cannot remember how i fixed it(i think it was
an /etc/services thing) ..help! :>

also anyone know of a program that can be used to test the server? at the
moment the only way i know of to test to see if ident replies(not just
connects, but replies) is to try to connect to an irc server that requires
identd. i checked out the RFC and tried to manually issue the commands via
telnet but it didnt work right :/

thanks a lot


Reply to: