[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X woes

  I'm having some problems with xfree86. I can't put my portuguese
keyboard working as it should. The layout is ok but the dead keys don't
work. I went to the symbols directory and altered the pt file so that the
dead keys work (substitued asciitilde, asciicircum, etc... for
dead_tilde, dead_circumflex, etc), and my XF86Config goes like this:

XkbRules	"xfree86"
XkbModel	"pc101"
XkbLayout	"pt"
XkbVariant	""
XkbOptions	""

After I exit x there is a message saying:

The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error:  	    No Symbols named "" in the include file "pt"
>		    Exiting
>		    Abandoning Symbols file "default"
Errors from xkbcomp are not fatal to the X server
Couldn't load XKB keymap, falling back to pre-XKB keymap

waiting for X server to shut down

I tried replacing "pt" in XkbLayout for "dk" or "es" and they have the
same error. I also replaced it for "us" and there is no error.

I also tried to change the config like this

XkbKeycodes	"xfree86"
XkbTypes	"default"
XkbCompat	"default"
XkbSymbols	"en_US(pc105)+pt"
XkbGeometry	"pc(pc105)" or "pc(pc101)" or "pc(pc102)"

and I get no error, but the keyboard doesn't work with dead keys. Can
anybody help with this?

  Problem 2:
  xfstt doesn't work. I changed the init.d so he has a different dir:

TTFDIR=/win/windows/fonts (yes, unfortunately I still use windows)

and added '--dir $TTFDIR' to the start-stop-daemon line (after the '--'
and before everything else). I still can't get no ttf fonts. <sigh>

This is annoying me senseless. Any suggestions?


Reply to: