[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Dependences Problem - dselect

I'm trying to install Debian slink over the web. I don't have the CDs. The base install from the floppy images goes ok & when debian.org is up I can update the packages. Now after 2 weeks of repeatedly trying & now using the 2/23/99 disk images & selecting the very smallest package, 25MB, this evening I got it to install over the web, I think. I've read all I can find on dselect, dpkg, installation instructions , v1 & 2 Debian manual & none of them cover my problem. The 'Q' command character in dselect doesn't do as the online documentation says & only lets it start the install until it checks the dependences & then it, I presume dselect, refuses to go ahead. I have a suspicion, with only scant evidence, that the following modules are set to both require the dependent modules/libraries & be incompatable with them.
libc6-dev 2.0.7t-1 requires libc6 2.0.7t-1  and
perl 5.004.04-6 requires perl-base 5.004.04-6
Yes, the dependent modules are selected to be installed but that doesn't help.

I selected Debian because of the completeness of the packages included & because of the volunteer nature of the project. However, this reminds me of the GNU software that I have tried to install & use a little in years past. As near as I could tell the programs worked well, with scant evidence, but I could never be sure what was going on since the documentation was mostly not there.

Reply to: