[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Communicator won't run. Help!

> I got the libc5 version from the supported directory.
> I am using tcsh. 

Also make sure that the environment variable MOZILLA_HOME is set to
point to /usr/local/netscape

> The $HOME is already set.
> here is the ldd output:
> ldd: version 1.9.9
>         libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0x4000d000)
>         libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40055000)
>         libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x4005e000)
>         libXmu.so.6 => /usr/X11R6/lib/libXmu.so.6 (0x40073000)
>         libXpm.so.4 => /usr/X11R6/lib/libXpm.so.4 (0x40085000)
>         libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x40093000)
>         libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x4009f000)
>         libdl.so.1 => /lib/libdl.so.1 (0x40143000)
>         libc.so.5 => /lib/libc.so.5 (0x40146000)
>         libg++.so.27 => /usr/lib/libc5-compat/libg++.so.27 (0x40206000)
>         libstdc++.so.27 => /usr/lib/libc5-compat/libstdc++.so.27
> (0x4023e000)
>         libm.so.5 => /lib/libm.so.5 (0x4026f000)
>         libc.so.6 => /lib/libc.so.6 (0x40278000)
>         ld-linux.so.2 => /lib/ld-linux.so.2 (0x4031d000)
> I also try to debug the netscape executable (although there is no
> debugging symbol). The seg fault seems to be in libc.so.5. 

Do the following and send me the output via personal email (do not mail
the mailing list) -

$ strace /usr/local/netscape/netscape

One thing you could try is moving the ~/.netscape directory out of the
way and starting communicator again.  If it starts fine, you can slowly
start moving files from your old ~/.netscape to your new ~/.netscape one
by one and see when the seg fault starts happening.

Homer: Oh Lisa!  There's no record of a hurricane ever hitting
Lisa: Yes, but the records only go back to 1978 when the Hall of
Records was mysteriously blown away.
Sudhakar C13n   http://people.netscape.com/thaths/   Indentured Slave

Reply to: