[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Install wierdness or newbie goes doh!

Desperately seeking help!

Think I'm doing something silly in my installation.  Is it necessary to
load/configure any modules for an integrated pci controller for ide
disk/cdrom (or for anything else - fairly plain vanilla system) using
the hamm cd's? If so, which ones? The install script doesn't seem to be
entirely clear on this one - or else i'm an idiot and need to learn to
read (entirely possible and quite likely).

Also I may need to add hdc=cdrom as a boot parameter for my cdrom (see
below) - I can't find anywhere obvious to do this in the install
script.  I tried adding the cdrom module and feeding it  hdc=cdrom as a
parameter - received error - this module does not accept command line
parameters or word to that effect.  Also tried modifying
/target/etc/lilo.conf from <Alt>F2 and installing it with "sbin/lilo -c
lilo.conf".  However I can't get the newly installed kernel to boot....
bit hard to know if this works!

If I'm not doing something silly I'm having what can only be described
as an interesting problem.

Gory details are:
Installing debian 2.0 from the hamm cd's (downloaded from
mirror.aarnet.edu.au).  Booting from a dos floppy with cd drivers and
running d:\install\boot.bat, boots into kernel from cd just fine.  After
installing kernels and base system, set to boot from hard drive, create
boot floppy.  Reboot from the hard drive:  see message "loading
linux..........."  before computer promptly hard resets itself.

I assume from this (dangerous, especially when you have no idea how the
kernel loads) that I have either misconfigured my kernel installation,
or that something in my BIOS isn't set right (doesn't like being
scanned? - however why does the kernel loaded from cd work if this is
the case?)

Saga continues:  boot from floppy - this works just fine.  Continue into
dselect and install packages o.k.  Reboot from hard drive, falls over.
Reboot from floppy, now it falls over too (??????????).  this continues
until a dos boot floppy and fdisk intervene. Try again - repartition,

Installation details:
Debian 2.0 hamm cd's - as far as I can tell kernel v2.0.34
No device drivers configured manually in script - is this right for
onboard ide controller for disk/cdrom?  tried loading linear disk device
and cdrom modules just in case, still fell over.

System details are:
- pentium 166 dual boot (when i can get to lilo!) windoze and
malfunctioning debian
- motherboard reports as 430VX rev3.0 chipset, Award PCI/ISA BIOS 4.51PG
with Plug and  Play BIOS extensions 1.0A
- 64mb of ram
- 2Gb mode-4 ide disk drive on hda (3 partitions - 1.2gb fat32, ~515mb
linux, 96mb linux swap)
- Generic ide cdrom (reported as CDROM 24X/AKOv by bios) on hdc
- internal modem on isa bus, set to COM4

Previously I have been running the slackware 3.0 release (not sure of
the kernel version - now in digital heaven) without any problems apart
from:  linux and win95 seem to have difficulty recognising my cdrom when
it is set as a  master.  Works fine as a slave.  When set as master,
under slackware needed to append "hdc=cdrom" in lilo.conf - with a 30
second delay in lilo windoze also recognises it (???) - otherwise need
to add device driver in config.sys.  Work that one out!  (cdrom is
listed as being detected at startup by the BIOS).

Thanks to Jaakko Niemi and Thomas Kocourek for the following info:
I swapped /dev/hdb (hard drive slave on primary bus) for /dev/hdc (cdrom
master on secondary bus). Two things have become self-evident:

1) If the kernel does not see any valid devices on the secondary IDE
bus, the kernel will disable the bus (this fact was unknown to me)

2) Some CDrom drives prefer to be slave drives and do not properly
respond to the kernel's inquiry when jumpered as a master drive (again,
an unknown fact)

Apologies for the lengthy post, but kind of confused at the moment.
Thanks in advance for any help/advice that anyone can give me.



Reply to: