[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Fujitsu Dynamo errors



I just bought a Fujutsu DynaMO 640SE magneto optical disk and am
having trouble getting it to work.  I have made progress by moving
from a 2.0.33 to a 2.0.34 kernel and am now able to partition it, but
it gets errors partway into mke2fs when writing inode tables.  Two
different disks will fail at different inodes, and the same disk will
fail at different inodes on different runs.  Before the 2.0.34 kernel
and 2048 byte sector patches, the drive was wrongly recognized as a
39mb removable drive.  Fdisk now correctly sees it with 620k 1k blocks.

When I installed the driver and utilities from the Fujitsu CDROM onto
Windows 3.1 and did a low level format and DOS format from Windows, I
was able to restore a 250mb backup tape to it and it worked fine.
Then tried another low level format and DOS format from Windows, then
came over and looked at it with Linux cfdisk, it only showed cylinders
1-151 of 606 mapped to a single partition.  Tried deleteing partition
and making the full disk a Linux type 83 partition, and then tried
mke2fs once again, and it still got the errors.


System:
ASUS P2L97S AGP motherboard (Pentium II 233mHz) 64mb
built-in AIC 7880 Adaptec SCSI controller on the motherboard.
Newly installed Debian 2.0 hamm system (upgraded from 1.3.1)
Installed and built kernel 2.0.34 including patches for Fujitsu
	2048 byte sector devices
SCSI host adapter in the middle of the chain, unterminated
TEAC CDR55S on internal end of chain, terminated - SCSI ID 1
Dynamo on external end of chain, terminated - SCSI ID 4

fdisk shows:
============
Disk /dev/sda: 64 heads, 32 sectors, 606 cylinders
Units = cylinders of 2048 * 512 bytes

   Device Boot   Begin    Start      End   Blocks   Id  System
/dev/sda1            1        1      606   620528   83  Linux native

errors from /var/log/syslog:
===========================
kernel: SCSI disk error : host 0 channel 0 id 4 lun 0 return code = 28000002
kernel: extra data not valid Current error sd08:01: sense key Illegal Request
kernel: Additional sense indicates Logical block address out of range
kernel: scsidisk I/O error: dev 08:01, sector 4260352, 
	absolute sector 4260480

I edited these slightly to make them less than 80 chars wide.  This is
the last one in the log.  There are over 28k instances of this
message, starting with absolute sector numbers around 1240000 and
going up to here (4260480).

SCSI driver startup from dmesg:
==============================
(scsi0) <Adaptec AIC-7880 Ultra SCSI host adapter> found at PCI 6/0
(scsi0) Wide Channel, SCSI ID=7, 16/255 SCBs
(scsi0) BIOS enabled, IO Port 0xd000, IRQ 10
(scsi0) IO Memory at 0xe1000000, MMAP Memory at 0x4805000
(scsi0) Resetting channel
(scsi0) Downloading sequencer code... 406 instructions downloaded
scsi0 : Adaptec AHA274x/284x/294x (EISA/VLB/PCI-Fast SCSI) 5.0.19/3.2.4
       <Adaptec AIC-7880 Ultra SCSI host adapter>
scsi : 1 host.
(scsi0:0:-1:-1) Scanning channel for devices.
  Vendor: TEAC      Model: CD-R55S           Rev: 1.0K
  Type:   CD-ROM                             ANSI SCSI revision: 02
Detected scsi CD-ROM sr0 at scsi0, channel 0, id 1, lun 0
  Vendor: FUJITSU   Model: M2513EL           Rev: 0020
  Type:   Optical Device                     ANSI SCSI revision: 02
Detected scsi removable disk sda at scsi0, channel 0, id 4, lun 0
scsi : detected 1 SCSI cdrom 1 SCSI disk total.
(scsi0:0:4:0) Synchronous at 10.0MHz, offset 15.
SCSI device sda: hdwr sector= 2048 bytes. Sectors= 310352 [606 MB] [0.6 GB]
sda: Write Protect is off



Thanks for any help that you can provide or point me to someone who can.

dion


Reply to: