[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

mailbox not deleted on inc!!!


My mail is behaving strangely.  I would incorporate my mail in exmh, and
then do it again and the same messages would be incorporated a second
time.  I had a look at /var/spool/mail/mark and discovered that it
wasn't being emptied when incorporated.  Indeed, this is what the
directory looked like:

# ls -laF /var/spool/mail/    
-rw-r--r--   1 mark     1000       294367 Dec 17 10:39 mark
-rw-------   1 mark     mail            0 Dec 17 10:58 mark.lock
-rw-rw----   1 paul     mail         1799 May  4  1997 paul

Now what is that "mark.lock" file all about?  I deleted the lock file, tried
incorporating again and same thing happened - and the lock file reappeared.
Also, the group and file permissions seem strange.  I decided to delete
the "mark" and "mark.lock" files and that seems to have solved the problem,
but I would like to know how the problem ever arose!

What was going on, and how did it get that way?



        "They told me I was gullible ... and I believed them!" 

Reply to: