[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

X on DELL laptop hangs

A friend of mine installed hamm on a Dell laptop with Neomagic video.  He got
X configured with the VGA16 server.  The X server seemed to work fine, but the
machine would invariably hang, shortly after quitting X or switching to
another virtual console.  By "hang", I mean that ugly state where the keyboard
and mouse don't respond, and a hard reboot is needed.

He also tried dropping in the SVGA server from XFree86 3.3.3, which handles
the Neomagic chip.  The same thing happened.

Ultimately, my friend installed a copy of RedHat 5.2, which worked fine, with
none of this problem.

I feel defeated and somewhat guilty, since it was partly at my urging that
this friend had tried Debian in the first place, so I'd really like to find
out what went wrong.  Also because another friend is on the virge (at my
urging, again!) of installing hamm on another Dell laptop (different model,

Has anybody seen a problem like this?  Please help!

Here are some more details:

  *  The problem seemed to occurs within a few seconds ( < 30? ) after
     switching to text mode (quitting X, or switching to virtual console).  We
     were able to get a shell prompt, even issue a few commands, and switch
     back an forth between the v.c. and the X screen a couple of times, before
     the system would just freeze.

  *  There was no noticeable problem on the screen.  No messed up images or

  *  The kernel was 2.34.

  *  The Debian was a 2.0 CD from Cheap Bytes -- not the "Official Debian",
     but C.B.'s own, with their own installation program.  I was struck by
     some odities, such as the absence of all the stuff I'm used to in the
     system logs (I'm running "official" hamm at home).  Could there be
     anything weird about this Cheap Bytes installation that's related to the
     X problem?

  *  I didn't think of checking the BIOS settings, for things like APM.  Could
     a broken APM cause symptoms like this?  Then again, isn't APM disabled in
     kernel-images that ship with Debian?

Thanks for any help.

David Zelinsky

Reply to: