[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Boot Param: floppy=thinkpad

"Ryan King" <rking@duke-energy.com> writes:
| I'm trying to install Debian on an IBM Thinkpad 755C, and was having
| trouble with the floppy drive during the installation.  (It does fine until
| time to install the drivers, and then all I get "/dev/fd0: Device not
| configured").
| When I `mount -t (ext2|msdos|dos|*) /dev/fd0 /mnt`,
| I get:
| "mount: /dev/fd0 is not a valid block device"
| (I tried mounting the Rescue disk, and then a spare disk, and then I tried
| mke2fs'ing the floppy then mounting, and they all did the same thing).
| Which leads me to the main problem (I think)
| While looking for the docs on mounting a floppy (I'm (obviously) a
| Linux-newbie), I ran across some info suggesting using floppy=thinkpad at
| the boot prompt, and it sounded relevant. However, when I try to enter it
| at the "boot:" prompt, it errors with:
| "Could not find kernel image: floppy=t.hin",
| and, apparently it gives a "floppy=x.xxx" message when it's not a valid
| param anyway, because "floppy=ryan" gives me:
| "Could not find kernel image: floppy=r.yan".
| I'd love any help, or (at this point), any ridicule that will point me in
| the vaguely right direction.

You need to give the kernel name first, then the parameters. On the
boot floppies I think it's just "linux". So, at the boot prompt, you'd

linux floppy=thinkpad

I've installed Debian successfully on two different 755C's and you do
indeed need the floppy=thinkpad parameter. 

I think there's a problem with battery charging though. Haven't paid
much attention to it since ours are plugged in all the time, but it
may be an issue for you.


Reply to: