[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Can not login: solved thanks to IRC guys.

Ok, I guess I will just go ahead and post the way it was solved.
Thank you, folks on IRC, for guiding me through this.

I don't know exactly WHY this happened to me, I believe I should have paid
more attention to README file for that utils-linux package.

Either use a rescue floppy (or, like me), at boot prompt type
linux init=/bin/sh
this will put you into shell.
If you are using lilo, / is most likely read-only. It says that in
lilo.conf, so I 
umount /
mount -n -o remount rw /

After that edit /etc/passwd, or /etc/shadow
In those files, there is a line that looks like:
root:xxxxxxx:yyyyy:zzzz: etc etc etc
Blank out the second part 
so it looks like
root::yyyyy:zzzzz etc etc etc

Then sync, and when hd stops spinning, reboot.
At prompt type in root, hit enter.
You should be taken straight into root account, where password can be

Never include a comment that will help | Andrew Ivanov
someone else understand your code.     | c680789@showme.missouri.edu
If they understand it, they don't      | ICQ: 12402354
need you.                              |

Reply to: