[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Mounting problem on cdrom

Wes Jennings wrote:

Hope someone can determine what this problem is. Outlined
below is information about my system, observations and error

1. I have had a Slackware Linux system, kernel 2.0.27, running
for about 1 year. All my hardware functions fine. I decided to
upgrade my system and wanted to try the Debian 2.0 release,
kernel 2.0.34. Instead of upgrading my Slackware system, disk
partition sdb1, I decided to split my dos disk in half and use
sda1 for dos and sda2 for a Debian partition. I want to play
around with a KISS Linux setup (non-windows) for command line
applications and emergency use. I figured I could learn the
Debian install routine on this new partition before tackling the
conversion of my main Linux partition from Slackware to Debian.
Here is some additional info that may be needed.

    Amd 5x86, 133 processor
    AMIBIOS, release 5/16/1996
    Adaptec 1520 SCSI card
    Hitachi CDR-1750S external SCSI cdrom

2. After backup my existing partitions and reading the install
documentation I started the Debian install using the floppy
disks for boot/rescue, drivers, and the basic disk sets
base144-1 thru 5. The install seemed to go alright. I was able
to setup LILO to boot from the hard drive. I also setup a boot
floppy. The system boots properly from both the hard drive and
boot floppy.

3. I did some more reading about dselect to be able to install
more of the Debian system. I then fired up dselect. Here,
however, I run into a serious problem getting dselect to mount
my SCSI cdrom. From dselect I choose Access, cdrom source, and
then filled out the device as /dev/scd0. The result was an
endless series of lines with the following message.

Aiee scheduling in interrupt 001260b1

I could not find a way to escape out of this endless message.

4. I next hit the reset button, Ctrl-Alt-Del did nothing, and
got the system back up. I next tried to manually mount the SCSI
cdrom in the Debian partition with the following command. 

mount -t iso9660 /dev/scd0 /mnt

The result was the same as in 3.

5. I then used a Slackware floppy to boot up the Slackware
partition. I tried to mount the cdrom with the exact same
command as in 4. and the cdrom mounted properly.

6. Next I wondered if the Debian distribution was using some
other system to refer to cdrom drives: like using /dev/scd1
instead of /dev/scd0. I tried all 7 files /dev/scd1-7 with the
manual mount command. None mounted, but there was no endless
messages as when I tried to manually mount /dev/scd0. So I
conclude that /dev/scd0 is the proper device file.

Now I'm getting desperate, and I tried some wild stuff to see if
I could shed some light on my problem and find a way to fix

7. Next I copied a Slackware kernel image that I knew would
mount the cdrom drive over to the Debian partition and made a
changed in a symbolic link as follows.

/vmlinuz > /boot/vmlinuz-slackware

I then booted the Debian partition, and things went along just
fine. Well until I tried to manually mount the cdrom. The result
was exactly the same as point 3. Oh well, I now know, from
experience, we can mix and match kernels if need be.

8. Please don't ask why, but I next tried to see if I could copy
device files. Could I possible copy the /dev/scd0 from Slackware
to my Debian partition? Well, I learned some crazy stuff can
happen. The following command   cp /dev/sda1 /dev/sda1.0   copied
the contents of my dos partition to file /dev/sda1.0. And this
command   cp /dev/scd1 /dev/scd1.0   returned the message 
cp: scd1: Device not configured.   But, cp /dev/scd0 dev/scd0.0 
did the unexpected. It sent the system into the same endless loop
of lines and message as when I attempted to mount the cdrom drive!

CONCLUSION - Well, my conclusion from all this, is something
must be wrong with file /dev/scd0. Well, it seems that this is
the case to this novice-intermediate Linux user.

QUESTION: If I have identified the problem correctly, what
should I do to get a good copy of the /dev/scd0 file onto my
Debian partition? And if I have mis-identified the problem, or
need to do some further testing (hacking?), please advise what
else I should do or consider.

A bit discouraged, but learning from this experience,
I too have had problems installing debian on a system with scsi.  My
computer has an adaptec 2840 scsi controller.  But I could not even
boot the kernel without disabling the scsi controller.  Problem is
that the stock kernel has EVERY scsi controller known built in.  And
the adaptec doesn't like it.  So I had to install a base system,
rebuild the kernel for ONLY the 2840, then configure in the scsi
devices.  I have a SCSI CD rom in this computer, and one at home
(using a 2920 controller) and both work fine, with custom kernels.  I
had to install onto an ide disk from an ide cd.  
Hmm got a thought, can you install slackware then install debian on
TOP of that using dselect?

Get your free @yahoo.com address at http://mail.yahoo.com

Reply to: