[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: dpkg/apt-get madness

> I tried "apt-get dist-upgrade" in order to upgrade to slink.
> Yes, I know slink is "unstable" so I might get some trouble.
> Packages were downloaded and processing started, then the trouble began:  
> I noticed that "startx" disappeared!  

I seemed to remember that the X11 maintainer specifically mailed to this
list that the slink X packages were severely broken and only to be used
by brave peoply meaning to help with the debugging process.

> Ok, this is probably temporary, I thought.  The new xserver package was
> not yet configured.  Then apt-get ended with an error. I tried re-running
> "apt-get  dist-upgrade" and "dpkg --configure -a" several times, and the
> problem seemed to be with the emacs20 package.  It could not be
> configured, any attempt ends in "memory errors" or "subprocess returned an
> error"

I also had lots of trouble with the emacs20 package on hamm.  Some
people suggested to remove the `tm' package.  This worked on certain
systems, but on other systems there was no `tm' present at all.  I got
this sorted out after installing emacs19, after which I could remove and
reinstall emacs20.  I suppose the emacsen system needs to get rid of its
sharp edges.

> I wanted X back, so I decided to get rid of emacs instead.  I don't use it
> much anyway.  "dpkg -r <emacs-packages>" removed everything except from
> emacs20:
> "The package is in a very bad inconsistent state - reinstall it before
> removing"

I believe that dpkg needs a --force-purge switch, to remove severely
broken packages.  Why doesn't it have one?


 E.L. Meijer (tgakem@chem.tue.nl)          | tel. office +31 40 2472189
 Eindhoven Univ. of Technology             | tel. lab.   +31 40 2475032
 Lab. for Catalysis and Inorg. Chem. (TAK) | tel. fax    +31 40 2455054

Reply to: