[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: About realplayer

On Fri, Sep 18, 1998 at 09:22:59AM -0700, Carl Johnson wrote:
> James Dietrich <jdietrch@southern.edu> writes:
> > I've followed this discussion on RealPlayer with interest, as RealPlayer
> > doesn't work on my system either--but it gives a different error.
> > 
> > A couple weeks ago I did a fresh install of Hamm (including RealPlayer)
> > and everything worked just fine.  However, after upgrading to Slink,
> > RealPlayer stopped working.  When I try to run the welcome.rm provided
> > there are a few frames of video and then it says this:
> > 
> > General error. An error occurred.
> > 
> > For more information, please see Error 1 at:
> > 	http://www.realaudio.com/help/errors
> > 
> > and goes no further.  The same thing happens when I click on a link in
> > Netscape--I get perhaps 1/3 second of video/sound and then the above error.
> > 
> > Yes, I'm using the Debian package, and yes, I have purged and reinstalled
> > it (several times) to no effect.
> > 
> > Anybody got any ideas?  Any more information about my system I'll be glad
> > to provide.
> I just went through this, but with different symptoms, so I can give
> some ideas where to look.  First, try running rvplayer from the
> command line, and see if it gives any error message.  In my case I was
> getting an error like:
>      ****audio: write error: -1 bytes errno: 5
> Also try checking the log files in /var/log.  I found messages (all
> the same) in messages, syslog, and kern.log.  In my case I had DMA
> errors, but it worked when I disabled 16-bit audio in the preferences
> menu.  I do have a 16-bit card, but obviously I don't have the 16-bit
> parts configured properly.  I don't think you have the same problem,
> since mine wasn't playing at all before I switched the preferences.

Thanks for your tips--but I am still having the same problem.

Actually, this morning I installed the most recent version of rvplayer
5.0-6--the one that uses the RedHat 5.x version from www.real.com. Now
it seems that I can listen to some files without trouble, while others
give trouble.  For example, the 14.4 news broadcast from
http://www.npr.org/news/ has no problems, but the 28.8 news broadcast
from the same site fails with the error message given above.  Others,
such as live RealVideo of NASA TV from http://quest.arc.nasa.gov/ltc/live/
play OK for a while and then fail with the same error.  And trying to
play the welcome.rm that comes with rvplayer from the commandline
fails immediately with that same error quoted above.

I can't seem to figure this out.  I have rebuilt my kernel with the
sound built in, instead of using a module to avoid any possible module
problems, and 'cat /dev/sndstat' shows everything installed properly.

Does anybody have any more ideas?  I would really like to have this
working properly :-)  If my description of the problem seems a bit
vague it is because there seems to be no definite cause or set of 
conditions that cause the error.  So I'll gladly try other things or
answer other questions about my setup if that will be helpful.

Thanks for your help!

James Dietrich

Reply to: