[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Broken emacs


I had a similar problem. How I solved it was to remove ALL
emacs packages including setup files. Re-install, being carefull
to install EXACTLY ONE emacs package. You may also install
EXACTLY ONE XEmacs package and get it to work. It appears that
it is quite easy to install more than one version of emacs
without it complaining, but then it will not configure without
complaining. I do not know if this is considered a bug or if
it has been submitted as one. Just know that this is what worked
for me.

On Thu, 10 Sep 1998, David R. Kohel wrote:

> I found some references to this in the July and August archives, 
> but has no fix been found for the emacs19 & emacs20 packages?  
> My apologies if there has been more recent discussion which I 
> did not find in my search.
> As far as I could tell, some people got them to install by 
> removing certain other packages, specifically "tm".  I have no 
> such package installed but installation STILL fails with emacs19 
> and emacs20.  
> I've done an essentially complete upgrade from bo to hamm, and 
> ended up purging the old "emacs" to start afresh when I met with 
> the initial errors.  
> The error message is the following:
> emacs-install emacs19
> emacsen-common: Handling install of emacsen flavor emacs19
> emacsen-common: byte-compiling for emacs19
> Warning: Lisp directory `/usr/local/share/emacs/19.34/site-lisp' does
> not exist.
> Warning: Lisp directory `/usr/local/share/emacs/site-lisp' does not exist.
> Cannot open load file: bytecomp
> emacs-install: /usr/lib/emacsen-common/packages/install/emacsen-common 
> emacs19 xemacs20 failed at /usr/lib/emacsen-common/emacs-install line 26.
> dpkg: error processing emacs19 (--install):
>  subprocess post-installation script returned error exit status 29
> Errors were encountered while processing:
>  emacs19
> ...and similarly for emacs20.  The lisp directory error seems to be 
> irrelevant.  The alternative solution from the archives, which I 
> eventually resorted to, is installation of xemacs, but it seems 
> more bulky than emacs and I use emacs typically in text mode anyway.  
> Does anyone have a fix in the works?  Or is there a list of 
> conflicting packages which need to be upgraded or removed in 
> order to do the installation?
> Thanks in advance for the help,
> David
> P.S.  If responding to the Debian-user list, please cc me in 
> response since I am not presently a subscriber, thanks.
> --  
> Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

/*********************** Running Debian Linux ***********************
*   For God so loved the world that He gave his only begotten Son,  *
*   that whoever believes in Him should not perish...    John 3:16  *
* W. Paul Mills              *  Topeka, Kansas, U.S.A.              *
* EMAIL= Paul@Mills-USA.com  *  WWW= http://Mills-USA.com/          *
* Bill, I was there several years ago, why would I want to go back? *
************ pgp public key emailto: key@mills-usa.com *************/

Version: 2.6.3a
Charset: noconv


Reply to: