[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Help] resc1440.bin (kernel) crash

On Fri, 21 Aug 1998 joost@pc47.mpn.cp.philips.com wrote:
> On Thu, 20 Aug 1998, Jimen Ching wrote:
> Instead, try to unpack base2_0.tgz directly onto your hosed system.  IIRC
> it contains all the necessary devices and essential libs.  Just boot the
> rescue floppy, switch to VC2 and mount your root filesystem on /mnt and

Thanks for pointing this out.  As I said before, I couldn't boot off the
rescue floppy (of Debian 2.0, cheapbytes), so I used the boot/root
floppies of Debian 1.1.  But it worked.  I repartition and started from
scratch.  It was easier this way. 

>   cpio -i -dbm < /path/to/base2_0.tgz

The Debian 1.1 boot/root disk had gzip and star (as another user
suggested).  I don't know how to use cpio either, so I use the star

>    dpkg --configure --pending
> I wouldn't be surprized if you got a lot of errors from that, but it

Actually, this didn't do anything.  It thought about it for a few minutes,
and took me back to the prompt.  ;-)

>   dpkg -iBOR /cdrom/debian/dists/stable/main/binary-i386
> That should just reinstall all packages that are registered to be
> installed on your system. 


Well, as an update.  The kernel crash problem was not reproducible
(easily) with a recompiled 2.0.34.  But I did once experience the crash.
I reset the computer and it didn't happen the second time.  So I don't
know what's wrong with kernel in the rescue disk.

I also enabled initrd in the kernels I built.  This did not fix the
problem I had with the boot sequence where it tries to mount the root fs.
The error message is something like:

RAMDISK:  Compressed file system found on block 0.
Kernel panic: VFS: unable to mount root fs on device 01:00

I can ctrl-alt-del my way out of this.  But enabling ramdisk and initrd
didn't help.  What is odd is that install.bat says the root device is
/dev/ram, and the rescue disk says the root device is /dev/ramdisk0. 
Neither of these exist in my /dev directory.  The Debian 1.1 boot/root
does have /dev/ramdisk0, though.  I'll try this and let you know if it is
the problem.

Now my system is back where it was, before all of this started.  I do have
a few questions about the new Debian version.

1.  How do I set my hostname?  Everywhere the hostname should appear, the
string "(none)" is placed there instead, no qoutes.

2.  Two files, fstab and resolv.conf were not created.  I had to manually
create these myself.  What did I do wrong that they weren't created?

3.  When I first got my system up, before installing a lot of optional
package, the nfsd and mountd were started.  I do not remember it asking me
whether I want these services started.  After I installed everything I
wanted, it didn't start these services anymore.  nfsiod is still a process
though.  Is this normal?

4.  I get this error in my /var/log/xdm-errors

System: `/usr/X11R6/lib/X11/xkb/xkbcomp -w 1 -R/usr/X11R6/lib/X11/xkb -xkm -m us -em1 "The XKEYBOARD keymap compiler (xkbcomp) reports:" -emp "> " -eml "Errors from xkbcomp are not fatal to the X server" keymap/xfree86 compiled/xfree86.xkm'

What is causing this?  How can I stop it from writing this to xdm-errors?

5.  I'm using fvwm2 as my window manager.  I added the following to my

Key Left  C R Scroll -100 0
Key Up    C R Scroll +0 -100
Key Right C R Scroll +100 +0
Key Down  C R Scroll +0 +100

I tried a bunch of other letters besides 'R', and it still doesn't allow
me to flip to another virtual screen.  I have setup the FvwmPager to be 3
by 3 screens.  So I should be able to switch to another screen.  I can do
it with the mouse, but I positioned the pager at the upper left hand
corner and it is sometimes a long distance to move the cursor.  How do I
setup fvwm2 so I can use ctrl-[arrow] to move between the virtual screens?
I should mention that I'm using the XKB extension for my keymap handling.
I was having problems with my delete and backspace key with the older
version of Debian.  I thought maybe this new extension in XFree 3.2.2
would help.  It didn't.  Or maybe I did something wrong?  I have the
101key keyboards.

6.  One more thing with fvwm2.  I added the following to .fvwm2/post.hook.

PixmapPath /usr/X11R6/include/X11/pixmaps

But I still do not see any of the pixmaps on the popup menu.  How do I
setup the configuration files so the pixmaps show up in the popup menus?

7.  I installed the scalable fonts for X.  Does anyone know how to access
these fonts from nedit? For some reason, the font looks really junk in

8.  I installed Xaw3dg.  I also enable the scrollbar in xterm.  For some
reason, the scrollbar foreground and background is black.  If it wasn't
for the outline of the scrollbar, I wouldn't be able to tell where the
scrollbar was located.  How do I change the scrollbar colors of xterm? 

Thanks in advance for any help.

Jimen Ching (WH6BRR)      jching@flex.com     wh6brr@uhm.ampr.org

Reply to: