[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Install 2.0 via FTP: doesn't like a 28.8 modem the OS/2 partition likes.

Brief summary:

In installed from the boot disk, booted to the linux partition, but
"pon" can't create a ppp connection to my ISP to install the rest via

My system:

486DX75, approx 800 meg IDE hard drive (western digital I think), local
bus, IDE CD-ROM (which OS/2 insists is a "Sony
CDU-55D,55E,76E,760E,77E"... hey, it works), an IDE (well, ATAPI) zip
drive, 3.5 drive A, 5.25 drive B, an 8 bit sound blaster from the dawn
of time, a local bus "does everything" type I/O controller that probably
has a garage door opener on it somewhere...

The problem component seems to be my generic 28.8 internal modem using 8
bits of a 16 bit ISA slot on COM3 using standard port/IRQ address. 
(COM1 is built into that controller card, but disabled via jumper.  OS/2
detects and used this modem just fine, I'm using it from my recently
shrunk (guess why) OS/2 partition to send email.)

The debian boot disks went down fine, I have a debian partition
installed on partition hd6 (OS/2's useless boot manager, OS/2 itself,
linux swap, and linux itself.)  It boots from a floppy to get to it, I
can login as root and cd around to my heart's content.

The "pon" script exits immediately of course, but "ps a" says it fired
off pppd which in turn fired off chat.  After around 30 seconds, chat
exits, so does pppd, and I still don't have a connection for dconfig to
FTP the rest of the base system through.  I copied all my ppp config
(user name, password, phone number) info from my OS/2 ppp dialer, where
it works, and entered it when prompted by install.  Double-checked, it
is correct.  (I even started over, reformatted and did all seven boot
disks again with the same result).  I've tried both ATZ and the init
string I hacked together way back before I misplaced the modem manual:
"AT&FE1M0&C1&D2W2".  Same result both times.  As far as I can tell, it's
not even picking up the phone.

Drawing on the fragments of unix I know from college (sunos 4) and a
little dabbling with AIX at IBM, I did the following, which may be a big
red herring for all I know:

on the alt-f1 tty:
cp /dev/ttyS2 /dev/console

on the alt-f2 tty:
cp /dev/console /dev/ttyS2

(If there's a dumb terminal program built into the OS, please let me

On alt-F2 I can type in ATDT[ENTER] and get the modem to pick up the
phone, but only after about a fifteen second delay.  It takes about the
same amount of time for ATH0[ENTER] to hang up the phone.  (Way back in
the dark ages I used a 300 baud modem, and it was WAY faster than this
response time.)  I sometimes (unpredictably) get my commands echoed back
to me on the alt-f1 console, and sometimes even a return code.  The
return code is numeric, despite the fact the long init string (Which
sometimes gets echoed back) says to return "OK".  I dunno what ATZ is
supposed to return.

I've tried 115k and 57600 port speeds.  (Well, in the ppp config file in
/usr/sbin/something_or_other.  I don't know how to set it manually.  I'm
installing this to learn, not because I already know it.)

I've been banging my head against this for two days.  I've read rather a
lot of Faq pages.  I went through the bug reports for PPP (couldn't find
one for the serial package).  Um... Help?  (Should I go back and try

Rob Landley

Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: