[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Apt upgrade

Daniel Mashao wrote:
> Has anyone been able to use the apt upgrade method to Hamm? I get all
> sorts of problems. First of all the installed system says it wants perl
> 5.004 I think. It has the following questions
>         require 5.004;
> Now my poor self is trying to reamin truly Debian and I have not seen perl
> version 5.004.
> Then it complains about there not being File::stat; I guess its because
> there is no correct perl version.
> Secondly using the sources.list file
> deb http://ftp1.us.debian.org/debian frozen main contrib non-free
> deb ftp://ftp.debian.org/debian frozen main contrib non-free
> deb http://non-us.debian.org/debian-non-US unstable/binary-$(ARCH)/
> which was the example file posted by someone on how to upgrade using apt I
> get the following error messages:
> Fetched 1420k in 0s (4282k/s)
> Updating package file cache...
> E: Opening
> /var/state/apt/lists/ftp.debian.org_debian_dists_frozen_main_binary-i386_Packages
> - ifstream::ifstream (2 No such file or directory)
> Anybody knows what is going on? And where can I get the required version
> of perl short of compiling one myself.

	You should start with the autoup script to start the upgrade process. 
Look in developer's corner on www.debian.org for it.  Perl 5.004 is
available as Debian packages; at least perl-base is a required package,
IIRC.  I'm pretty sure these perl packages are one of the things autoup
will do for you.


Unsubscribe?  mail -s unsubscribe debian-user-request@lists.debian.org < /dev/null

Reply to: