[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

more SCSI Woes


Ok I got a differt SCSI card...the only one I could find in a reasonable 
price range locally was an Adaptec 1520 ...it is suported by the
152x driver I should hope...
here is the problem...
it coems up..in SCSI Bios and with jumpers I have set:
IRQ: 10 (also tried 11, and 9...all of which have the same behaviour)
io: 0x340 (also tried 0x140)
BIOS Adress DC000
..the SCSI bios detects my tape drive (SCSI ID 4)
then linux boots (command line aha152x="ioport,irq")
it BIOS test Passed...
other stuff...
"aha152x: trying software interrupt lost"
and "aha152x: IRQ (the IRQ I chose and appended in lilo) possibly wrong.."
then it says that every ID it tries is timing out

scsi : aborting command due to timeout : pid 6, scsi0, channel 0, id 6,
lun 0 Test Unit Ready 00 00 00 00 00 

anyway...I did a "cat /proc/intterupts" and got:
[sjc@Shit-Box sjc]$ cat /proc/interrupts 
 0:     386167   timer
 1:      10542   keyboard
 2:          0   cascade
 4:     123116 + serial
 5:        165   NE2000
 8:          2 + rtc
12:     150329   PS/2 Mouse
13:          1   math error
14:      49013 + ide0
15:          0 + ide1
and: (ioports)
[sjc@Shit-Box sjc]$ cat /proc/ioports 
0000-001f : dma1
0020-003f : pic1
0040-005f : timer
0060-006f : keyboard
0070-007f : rtc
0080-008f : dma page reg
00a0-00bf : pic2
00c0-00df : dma2
00f0-00ff : npu
0140-015f : aha152x
0170-0177 : ide1
01f0-01f7 : ide0
0300-031f : NE2000
0376-0376 : ide1
0378-037f : lp
03c0-03df : vga+
03f0-03f5 : floppy
03f6-03f6 : ide0
03f7-03f7 : floppy DIR
03f8-03ff : serial(set)

What could possibly be wrong? I have tried every feasable setting...
and the SCSI BIOS detects the tape drive (and I have SCSI Tape Drive
suport compiled in kernel)
..I posted earlier...
someone suggested verifing the interupts and trying the other
ioport...I have...im even using a new adapter
I have never tried to setup SCSI before (on aPC...SCSI setup
was a no brainer on my Apple II GS way back when (shamefully I admit
way back when was 3 years ago)
this is starting to get frustrating...what could it be?
I NEED backup capability I read the SCSI HOWTO...still no help
same for the kernel SCSI readmes
- -Steve

Version: 2.6.3a
Charset: noconv


To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

Reply to: