[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

wierd ppp/pon bug?

An odd thing happens when I have been connected for many (many) hours,
generally anywhere from 6 to 12 or so.  It is not like the standard
bootings (attack dialing takes care of those :).  The modem connects, does
some sqweeking, then starts going bee-bee-boooop, high tones to low with
lengths as implied.  I always assumed this was a thing my university ISP
did to defend themselves from attack scripts like mine, but one day this
behavior continued for a dozen or so hours and I called the techies there
in search of a way to make reparation.  They said they didn't know of
anything spooky on their end, and suggested I reboot.  Knowing what I know
of linux, I didn't think much of this suggestion, but I tried it.  After
rebooting, the next time I dialed it worked.  This has happened twice now.
I suspect a bug somewhere in ppp on the pon script, or possibly in the
kernel.  Restarting ppp (and killing the chat process) doesn't fix the
problem though.  I noticed the following message when I halted the system:

Send ... TERM signal
lp1 out of paper         <---
Send...  KILL signal

which I have never observed before. I am reasonably certian there was
nothing in the print Q, but there may have been.  I include this only in
case there is something suggestive about it.

GNU GPL: "The Source will be with you... always."
(sig assumed to be GPLed)

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: