[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: boot/mount more info and 2 more questions

T-SNAKE <tsnake@rhombus.net> writes:

> #1
> OK, I got my /etc/fstab file here (mostly):
> #<file system>    <mount point>    <type>    <options>  <dump>  <pass>
> /dev/hda2            /              ext2      defaults    0       1
> /dev/hda3            none           swap      sw          0       0
> /dev/hda4            /usr           ext2      defaults    0       0
> /dev/hdb2            /dos           msdos     defaults    0       0
> proc                 /proc          proc      defaults    0       0
> This sets off something that messes up paths somehow. Even during boot, I see
> messeges about  ..../boot.d... command not found (forgot to write that part
> down). And when I log in, even as root, I can't do much, because my paths are
> all but gone. No X, no pico, nothing... just ls, shutdown and a few others
> (that I've noticed). So, what could be wrong.
> The version that works just fine is when I take out the hda4 and hdb2 mounts.

You have installed debian and then added the hda4 partition, right?
So if you add this line, the hda4 partition will hide the contents of your
previous /usr, so you can't access the files stored there.

No big problem. You mount hda4 on /mnt and move the content of /usr to
/mnt. Then you remount hda4 on /usr and are done. There are some foolproof
methods to do this transfer which all escape me at the moment :-) 
Someone else will tell you what to do. Something with cp -a or tar and

> #2
> This strange thing happened to me this morning when I booted to get the fstab
> info. It halted booting after these three lines:
> VFS: Mounted root (ext2 filesystem) read only
> INIT: verison 2.71 booting
> INIT: PANIC: segmentation violation! giving up...

I never had a kernelpanic. Some flaw in Hardware maybe. The RAM, 133 MHz
Prozessor running at 166 or such.

> #3
> Though my X setup hasn't met with a lot of success, it at least loads up and I
> canget a few terms open. I haven't been able to figure out much yet, but
> anyway, when I am in X (using xdm and I *think* fvwm2 (but I don't even know
> how to tell for sure... there's WAY too many different files and configs, so
> actually don't know what's controlling what) 

Did you try clicking on the root window (the background)? Then you should
get a menu of applications if you have the menu package installed.

Run "ps -axf|less" and you will see for sure which windowmanager you use.

I' using fvwm2

 217  ?  S      0:00 /usr/bin/X11/xdm
  220  ?  S      0:42  \_ /usr/X11R6/bin/X -auth /var/lib/xdm/authdir/authfile
  222  ?  S      0:00  \_ -:0
  238  ?  S      0:02      \_ /usr/X11R6/bin/fvwm2         

> I can't seem to get out without
> running a shutdown command in the term. If I ctrl-alt-bksp it exits to a
> command prompt, but then goes right into another X session. HUH?!?! Am I
> missing something here?

No. You are running xdm. You get a small window in X asking for username
and password, right?

If you close your xdm session, xdm will automaticaly start a new
login. This is a feature.

To get back to the console use CTRL-ALT-Fx where x=1..6
To get back to X press CTRL-ALT-F7


TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: