[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem dialing in w/AutoPPP/PAP! Help!



On Wed, 14 Jan 1998, Jeff Noxon wrote:

I have exactly the same question! Upgraded from 2.2.0f to 2.3.2 and PAP
stopped working from /etc/shadow. I thought it's libpam0g but after
installing them all it still does not work.

If you - or anyone - get the answer I'd be very interested as well!

> I'm trying to get mgetty's AutoPPP feature to work with PAP in PPPD to allow
> users to dial in with Win95 and Linux.  So far, no go.  I am dialing my own
> ISP with PAP and it works great.
> 
> When I crank up logging, I see this:
> 
> pppd[24325]: pppd 2.3.2 started by LOGIN, uid 0
> pppd[24325]: Using interface ppp1
> pppd[24325]: Connect: ppp1 <--> /dev/ttyC1
> pppd[24325]: sent [LCP ConfReq id=0x1 <mru 542> <auth pap> <magic 0xffff01ab> <pcomp> <accomp>]
> pppd[24325]: rcvd [LCP ConfAck id=0x1 <mru 542> <auth pap> <magic 0xffff01ab> <pcomp> <accomp>]
> pppd[24325]: rcvd [LCP ConfReq id=0x1 <mru 1500> <magic 0x6be65f78> <pcomp> <accomp>]
> pppd[24325]: sent [LCP ConfAck id=0x1 <mru 1500> <magic 0x6be65f78> <pcomp> <accomp>]
> pppd[24325]: rcvd [PAP AuthReq id=0x1 user="pierre" password="<censored>"]
> pppd[24325]: PAP authentication failure for pierre
> pppd[24325]: sent [PAP AuthNak id=0x1 "Login incorrect"]
> pppd[24325]: sent [LCP TermReq id=0x2 "Authentication failed"]
> pppd[24325]: rcvd [LCP TermAck id=0x2]
> pppd[24325]: Connection terminated.
> pppd[24325]: Hangup (SIGHUP)
> pppd[24325]: Exit.
> 
> The log on the other side of the link is similar.
> 
> I've tried using ppp, ppp-pam, reinstalled both, and tried almost every
> variation I could think of in pap-secrets.  The user/password pair work
> fine and are being transmitted fine.
> 
> The other side of the link is running bo, with ppp-2.2.0f.  I haven't
> tried Microsoft yet -- don't see the point, since it looks like my side
> that's having the cow.
> 
> Any help would be greatly appreciated!
> 

cya
peter



--
TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .


Reply to: