[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

BS in rxvt+ncurses


	I've already asked this, and I'm sure someone must be having the
same problem...

No matter how I set the backspace in X11, it won't work under rxvt +
some ncurses program, for example, pine. At some point the entry in
/etc/terminfo/r/rxvt was changed, and the backspace stopped working. The
change isn't documented in the Debian changelog, it just says "Munged
rxvt entry a bit more", and also makes reference to an update to the
terminfo database...  

xterm does work, and infocmp says:

comparing rxvt to xterm.
    comparing booleans.
    comparing numbers.
        colors: -1:8.
        pairs: -1:64.
    comparing strings.
        hpa: NULL, '\E[%i%p1%dG'.
        kend: '\E[4~', '\E[F'.
        khome: '\E[1~', '\E[H'.
        kmous: NULL, '\E[M'.
        vpa: NULL, '\E[%i%p1%dd'.

I don't see anything relevant here. There are far more differences
between the entry that worked and the one that doesn't.

I have:

ii  ncurses-base    1.9.9g-6
ii  rxvt            2.20-8

The only thing I see that may be relevant is that xterm does use
libncurses and rxvt doesn't. I don't think rxvt is broken... it worked
before... the problem is, I don't know before what. Also, I don't want
to blindy move the old entry over the new one, because I see there are
other differences between them and some of them are indeed good. 

Thank you very much in advance (I mean it, this is getting annoying)

			Marcelo Magallón

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org .
Trouble?  e-mail to templin@bucknell.edu .

Reply to: