[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: yet another ppp problem

--- You wrote:
> Hello,
>      I am a new debian user.  I have had my system running for about a month
> now.  I am trying to set up ppp so that I can dial in to school from my home. 
> I don't really know what I am doing, so like any good newbie, I poured over
> /usr/doc and /usr/doc/HOWTO directories.  There seemed to be two different
> schemes running around the documentation.  One using pon, and the other using
> ppp-on (I am not really sure if they are the same or not).  Anyway, I have
> tried the latter approach.
>     I set up a /usr/sbin/ppp-on script


Yeah. I had to do exactly the same when I was using Slackware :(
In Debian all appropriate files and scripts are already set up
for you:

those are /etc/ppp.options_out and /etc/ppp.chatscript

There should be no comments in those files!

Make sure to add in /etc/ppp.options_out the following options:

user Larry.Gariepy and (if you ISP uses PAP authorization) edit
/etc/ppp/pap-secrets  to add the following line:
Larry.Gariepy   *   <your real password>

After that start ppp with "pon" .

Alex Y.

--- end of quote ---

OK.  Now that I know that this is the Debian way, I am happy to do it this way. 
I tried this, and it was a beautiful thing to hear the modem connecting...but
it didn't work.  I'm going to include my /etc/ppp.options_out,
/etc/ppp.chatscript, and the final "plog".

defaultroute /dev/ttyS1 57600 persist
user Larry.Gariepy

""           ATDT16036430102
name         Larry.Gariepy
word         \qboffo17\q
ready        ppp

"plog" output:
Nov 26 03:03:54 gariepy pppd[440]: Serial connection established.
Nov 26 03:03:55 gariepy pppd[440]: Using interface ppp0
Nov 26 03:03:55 gariepy pppd[440]: Connect: ppp0 <--> /dev/modem
Nov 26 03:04:01 gariepy pppd[440]: local  IP address
Nov 26 03:04:01 gariepy pppd[440]: remote IP address
Nov 26 03:04:01 gariepy pppd[440]: ppp not replacing existing default route to
Nov 26 03:04:01 gariepy pppd[440]: Cannot determine ethernet address for proxy

So when I start ppp with pon, it gets this far, and doesn't do anything. 
"ifconfig" seems to think that my connection is working.  What is curious is
that the last two lines of the "plog" output never make it to

Larry Gariepy

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: