[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

startx -- -bpp 16 doesn't work

I am running the SVGA server, and am unable to start X Windows in 16 bit
mode.  I tried this command:

startx -- -bpp 16

and got this message:

SVGA: Linear addressing is required for 16bpp

 *** A configured device found, but display modes could not be

There is a message in XF86Config that says:

# To allow linear addressing, uncomment the Option line and the
# address that the card maps the framebuffer to.

so I edited my XF86Config file and uncommented Option "linear"
There are two entries right above Option "linear" with addresses:

#MemBase 0x00e00000
#MemBase 0x04e00000

I didn't know which one to try, so I tried one, then the other.  If
neither of those is my MemBase address, I don't know how to find it.

Anyway, I always get the same result.  When I try startx -- -bpp 16,
my screen comes up totally black and when I click the mouse to drop
the xterm window (I am running TWM) the mouse locks up.  After 30
seconds or so I can move the mouse around the screen, so long as I
don't move it over the xterm window, in which case it will lock up
again.  The xterm window does appear to be in higher resolution.

If I click the mouse button away from the xterm screen, the green
rectangular menu appears, but I can't read the menu items in it.
However If I move to the bottom of the rectangle (where the exit
commands is), I can exit X Windows normally, even though I can't read
the menu.  When X shuts down, I see this message:

Cirrus: BitBLT engine time-out.
Cirrus: BitBLT engine time-out.
Cirrus: BitBLT engine time-out.
Cirrus: BitBLT engine time-out.
Cirrus: BitBLT engine time-out.
Cirrus: BitBLT engine time-out.

waiting for X server to shut down

So I tried Option "no_bitblt" as well as Option "noaccel".  Under these
conditions, X starts with a black screen and some colored bars near the
top of the screen, and no xterm window is visible at all.  I know it's
there because if I position the mouse in the center of the screen I can
type commands and they will execute.  For example I can play a sound
file, even though I can't see what I'm typing.  I can also exit as
before, but now I can't see the rectangular menu.  If I click the screen
and guess how far to move the mouse, I can get the exit command to work
(it usually takes several tries).

Here is as much of the screen output as I could get with SHIFT+PAGE UP
when X shuts down under there conditions.

(--) SVGA: Mode "1800X1440" needs hsync freq of 96.15 kHz. Deleted.
(--) SVGA: Mode "1800X1440" needs hsync freq of 104.52 kHz. Deleted.
(**) FontPath set to
(--) SVGA: chipset:  clgd5429
(--) SVGA: videoram: 1024k
(--) SVGA: clocks:  25.23  28.32  41.16  36.08  31.50  39.99  45.08 
(**) SVGA: Option "linear"
(**) SVGA: Option "no_bitblt"
(**) SVGA: Using 16 bpp, Depth 16, Color weight: 565
(--) SVGA: Maximum allowed dot-clock: 52.065 MHz
(**) SVGA: Mode "640x480": mode clock =  31.500, clock used =  31.499
(**) SVGA: Mode "800x600": mode clock =  40.000, clock used =  39.991
(--) SVGA: Virtual resolution set to 800x600
(--) SVGA: SpeedUp code selection modified because virtualX != 1024
(--) SVGA: clgd5429: Internal memory clock register is 0x20 (Standard
(**) SVGA: clgd5429: Approximate DRAM bandwidth for drawing: 51 of 114
(--) SVGA: clgd5429: Using linear framebuffer at 0x03e00000 (62MB)
(--) SVGA: clgd5429: 88576 bytes off-screen memory available
(--) SVGA: clgd5429: Using hardware cursor
(--) SVGA: clgd5429: Using accelerator functions
(--) SVGA: Using XAA (XFree86 Acceleration Architecture)
(--) SVGA: XAA: No acceleration primitives defined.

waiting for X server to shut down

If anyone can give me a clue about this, I would be greatly

David Densmore <dden@rollanet.org>

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: