[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libc5 vs libc6

Phil Nitschke <phil@mrad.com.au> writes:
> I'm trying to delete older version(s) of tcl and Tk and install Tcl8.0
> and Tk8.0 using dselect (kernel rev. 2.0.30).
> The problem is that Tk8 requires libc6 which conflicts with libc5
> which is required by half the other applications I've got installed.

You're wrong about libc6 conflicting with libc5:

    blp:/raid/home/blp$ dpkg -s libc6
    Package: libc6
    Status: install ok installed
    Priority: required
    Section: base
    Installed-Size: 1421
    Maintainer: Helmut Geyer <Helmut.Geyer@iwr.uni-heidelberg.de>
    Source: glibc
    Version: 2.0.5c-0.1
    Pre-Depends: ldso (>= 1.8.10-1)
    Conflicts: libpthread0 (<= 0.5-10)
    Description: The GNU C library version 2 (run-time files).
     Includes shared libraries needed to run programs.

However, libc6-dev and libc5-dev conflict.  Your programs shouldn't
depend on these, however; only development libraries should.
Ben Pfaff <pfaffben@pilot.msu.edu> <blp@gnu.org> <pfaffben@debian.org>
Senders of unsolicited commercial e-mail will receive free 32MB core files!

TO UNSUBSCRIBE FROM THIS MAILING LIST: e-mail the word "unsubscribe" to
debian-user-request@lists.debian.org . 
Trouble?  e-mail to templin@bucknell.edu .

Reply to: